External HD showning as "no name" & all files gone

Discussion in 'Mac Basics and Help' started by Danny P, Sep 24, 2009.

  1. Danny P macrumors newbie

    Joined:
    Sep 24, 2009
    #1
    Hi, just wondering can anyone here help with this..

    I have an Iomega external USB drive and up until
    yesterday it was working fine, then yesterday evening
    I noticed that the name had changed to "no name"
    and all the files are gone, just nothing inside when I click
    on it.

    When I go to get info it shows that 56GB is used, so
    the files must be on it somewhere.. If anyone can help
    me get them I would be really grateful.

    Cheers

    D
     
  2. Poncho macrumors 6502

    Poncho

    Joined:
    Jun 15, 2007
    Location:
    Holland
    #2
    Launch disk utility and see what this tell syou about tdisk.

    Try a disk repair.

    Could be a number of things, from a corrupt directory to a dodgy USB lead. Have you got another mac you can plug it into.
    Also try plugging it in to a different USB port on your Mac.

    The most important thing is not to do anything with the drive that might delete any of the data on it because you might well b able to get it back via software like DiskWarrior that can search the drive and build you another directory which will allow you to see all your files again.

    You can download a trial of diskwarrior here.

    http://mac.softpedia.com/get/System-Utilities/DiskWarrior.shtml

    The trial version might be neough to get your stuff back, don't know.
     
  3. Danny P thread starter macrumors newbie

    Joined:
    Sep 24, 2009
    #3
    Thanks for getting back Poncho, yeah tried a repair disk
    but just on the "no name" part, the whole disk is showing
    up as a toshiba and no name is like a directory of it,

    Should I try a disk repair on the Toshiba disk itself?

    Anyway when I did it on "no name" it said

    1 non HFS volume checked
    No repairs were necessary

    Tried to download a demo of Disk warrior as well but
    I think they only have the full version...


    Thanks again for your help

    D
     

Share This Page