External HD slowing everything down

Discussion in 'iMac' started by eddjedi, Jul 28, 2012.

  1. eddjedi macrumors regular

    Joined:
    Sep 7, 2011
    #1
    Having my external Time Machine HD plugged in all the time is really bugging me. Basically whenever the computer tries to access the drive, it stalls the whole machine for 2-3 seconds while the drive wakes up (you can hear the spindle slowly whir up to full speed.) I obviously realise that with traditional HDs this is a necessary evil when it actually NEEDS to access the HD and it's asleep, but why does it stall my computer when it boots up? Or while I'm web browsing? Surely if my boot drive is designated as the internal HD, why does it wait for the slow external HD to wake before it starts booting?

    This isn't a new issue, I've had it with every computer for as long as I can remember, I just don't understand why nobody has ever addressed it.
     
  2. AndyCarolan macrumors member

    Joined:
    Jun 25, 2012
    Location:
    UK
    #2
    Is there not a power saving setting that can override the drive spin down sequence?
     
  3. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #3
    There is.

    System Preferences > Energy Saver > checkbox for "put hard disk(s) to sleep when possible".

    I assume this relates to the internal drives, but not 100% sure about external connected drives. It would be the first thing I'd check though. Note that this will mean your drive is spun up the whole time that your Mac is awake.
     
  4. AndyCarolan macrumors member

    Joined:
    Jun 25, 2012
    Location:
    UK
    #4
    Cool :)

    Yes, big downside with it being all all the time.

    Is it possible to adjust the interval at which TM backs up to the drive? This could be set to reduce the amount of times that the drive is accessed perhaps?
     
  5. eddjedi thread starter macrumors regular

    Joined:
    Sep 7, 2011
    #5
    Thanks for the replies. This is for my external drive so I don't think that will work. It seems to go to sleep within an hour, and also is obviously asleep before I turn the Mac on. It's just annoying that it wastes 5 seconds at boot up spinning up when it's not even needed, and often I'm doing something that has absolutely nothing to do with that drive but I get the wheel of death until it's spun up to speed.
     
  6. excommie macrumors regular

    Joined:
    May 12, 2009
    #6
    This setting is for external and internal drives. I use few FW800 drives (including booting my iMac from FW800-SSD drive), this checkbox is clear and don't experience anything like OP is describing.
     
  7. 141n5 macrumors member

    Joined:
    Mar 11, 2012
    Location:
    Scotland
    #7
    I have this exact same problem with my 2TB WD My Book Studio Edition II on FW800.

    I have no WD software installed on the mac.

    On nearly every search and TM action the drive waking is stopping my computer dead for a good 10 seconds

    I have tried searching the net and adjusting the Power saving settings, I just can't find a way to stop this from happening.

    I even bought a ReadyNAS to put on the network as an alternative and it has been next to useless, so I am stuck with this for now.

    Any help? very much obliged.
     

Share This Page