External HD will not show up on Mini

Discussion in 'Mac mini' started by Heavy Fluid, Jul 15, 2013.

  1. Heavy Fluid macrumors 6502

    Joined:
    Jun 18, 2008
    #1
    A little while back, I thought I lost my Mini. Power supply or something quit. Saved the HD, placed it in a dock, and all was good. Connected it to my Chromebook, and it mounted, everything was still there.

    Fast forward to today, finally got around to hooking it up to my brand new Mini that I got last week, and lo and behold, it will not mount. Tried all of the USB ports on the back, nothing. Tried the USB port on the keyboard, nothing. Hooked up 5 different jump drives on all the USB ports, and they all mount. OK, weird. Hook the dock up to the Chromebook again, and it mounts.

    What in the heck am I doing, or not doing??????
     
  2. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #2
    Is it formatted HFS+/journaled? Also I find when that happens if you can reformat then it usually fixes the issue.
     
  3. Heavy Fluid thread starter macrumors 6502

    Joined:
    Jun 18, 2008
    #3
    Not sure what that means, nor do I even know where to begin to find that out??

    I just want to pull the music/pictures off my old HD, and put them on the new one.
     
  4. Jambalaya macrumors 6502a

    Joined:
    Jun 21, 2013
    Location:
    UK
    #4
    Reformatting will (I think) erase all your data so don't do that.

    If it mounts on the Chrome book why don't you use that to transfer contents to one of the other drives that does mount on the Mac ?

    When you have all the data on the Mac you can try reformatting (using disk utility) and seeing if that cures the problem so you can use the disk again
     
  5. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #5
    Of course reformatting erases all data. I assumed this was understood. As you said, moved the data first to another drive then reformat.
     
  6. scbond macrumors 6502

    Joined:
    Oct 16, 2010
    Location:
    Nottingham, UK
    #6
    HFS+ is the standard Mac format for disks, like what NTFS is to Windows. Open up Disk Utility and see if the disk shows up in there and, if it does, you can see information about it and format it from there. If there's nothing important on there then I'd reformat it but if there is important stuff on there then try saving it using another computer which does recognise it. I would assume that Chrome OS have interfered with it.
     
  7. Heavy Fluid thread starter macrumors 6502

    Joined:
    Jun 18, 2008
    #7
    I looked under Disk Utility, and this is what it says:
    Name : Hitachi HTS543216L9SA02 Media
    Type : Disk

    Partition Map Scheme : GUID Partition Table
    Disk Identifier : disk1
    Media Name : Hitachi HTS543216L9SA02 Media
    Media Type : Generic
    Connection Bus : USB
    USB Serial Number : 0010101E40000000
    Device Tree : IODeviceTree:/PCI0@0/EHC2@1A
    Writable : Yes
    Ejectable : Yes
    Location : External
    Total Capacity : 160.04 GB (160,041,885,696 Bytes)
    Disk Number : 1
    Partition Number : 0
    S.M.A.R.T. Status : Not Supported
     
  8. famous600 macrumors 6502a

    famous600

    Joined:
    Apr 8, 2010
    #8
    In finder, click preferences and make sure show external disks on desktop is checked :)
     
  9. Heavy Fluid thread starter macrumors 6502

    Joined:
    Jun 18, 2008
    #9
    I already ensured that it was enabled, and it is. Still does not show up.
     
  10. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #10
    Try a different dock or enclosure if you can.
     
  11. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #11
    SInce Disk Utility can see it, it probably works. Select it in Disk Utility and click the Mount button.
     
  12. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #12
    In situations like this, often the best answer is "do whatever works for you".

    Since you can still mount the problem drive on the Chromebook, I suggest you do this:
    - mount the drive on the chromebook
    - use the USB flash drives (or whatever other drive you have available that is mountable on BOTH the Chromebook AND the Mini)
    - copy the files in question from the problem drive to the flash drives this way (I realize that if a great deal of data is involved, "multiple passes" may be required)
    - copy all that data over to the Mini

    Once that has been successfully completed, do this:
    - reconnect the problem drive to the Mini
    - use Disk Utility to re-initialize it to HFS+ (GUID partition table)
    - TEST the re-initialized drive with DU's "repair" button
    - I suggest you run "repair disk" several times (5 successive times with no errors would be a good move)
    - if at this point the drive re-initializes and tests OK, then I would consider it safe to use for data storage
     
  13. Heavy Fluid thread starter macrumors 6502

    Joined:
    Jun 18, 2008
    #13
    Mount button is greyed out, not available.

    I guess that I will have to do the multiple passes with a drive. 8gb is the biggest I have, so it might not be too bad.
     

Share This Page