External HD won't mount, verify or repair... PLEASE HELP

Discussion in 'Mac Basics and Help' started by Tooly57, Apr 2, 2012.

  1. Tooly57 macrumors newbie

    Joined:
    Apr 2, 2012
    #1
    Hi everybody, i has a problem i haven't been able to find a fix for and after spending far too much time trawling the net for info i'm about ready to give up.
    As a relative novice I have learned quite a bit from reading through threads on this forum, so thanks for sharing your knowledge and time, hopefully someone can help me out.
    The problem is with my WD Elements 1tb "mybook" external drive.
    It has worked fine for over a year on my previous desktop Mac and my macbook laptop (OS 10.4.11) as well as playing videos and music through a WD media player that's plugged into the TV. :D
    I recently plugged it into my new desktop Mac, which is running Lion, and it came up with an error and wouldn't mount, although the WD CD icon that always accompanied the Mybook icon still shows on the desktop. Tried it on the previous desktop cpu (where it had worked before) and the same thing happened. :(
    Tried it in the laptop again and no error message appeared :) but it still won't mount. :( It shows up in Disk Utility but when i try to verify or repair it i get a message saying some sort of error occurred, so it still won't mount. :mad:
    The strange part (to me at least) is that the hard drive still works just fine when it's plugged into the media player and TV. I can still see everything on the hard drive, but i can't get it to mount on a cpu so i can edit it's contents.
    WTFudge? :confused:
    Thanks in advance,
    Tooly
     
  2. Tooly57 thread starter macrumors newbie

    Joined:
    Apr 2, 2012
    #3
    Thanks for that, I'm not worried if i can't use the external drive with Lion as i plan on getting a new one soon anyway but i'd like to be able to still use the my book on my old OS 10.4 laptop if i can.
     
  3. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Have you tried repairing it? It's a long shot, and if you have critical stuff on there I would backup first. Then try a DU repair. If that comes back clean, try repairing permissions on the drive.
     

Share This Page