External HD won't mount

Discussion in 'MacBook' started by CBA, Jun 13, 2008.

  1. CBA macrumors newbie

    Joined:
    Apr 30, 2008
    #1
    Hi
    I have an external hardrive that I by mistake disconnected without dragging it to the trash on the desktop first. Now it won't mount, like a file "flag" is mislocated (or something). I have tried to restart it both HD and macbook with no luck. I now get the :"Initialize, Ignore, or Eject" option when I connect it. If I hit initialize I guess it will delete it all.

    Is there anyway to salvage the data?

    btw the drive is in FAT32 format that I have had from when I use a PC, and I had just transfered a file to it from a PC, uplugged it and managed to transfer the file onto the Macbook.
     
  2. LaDirection macrumors 6502

    Joined:
    Jul 14, 2006
    #2
    This happens all the time to everyone using these things. Use Diskwarrior. This has worked 100% of the time for and everyone I know.

    You can buy it or... you know.
     
  3. CBA thread starter macrumors newbie

    Joined:
    Apr 30, 2008
    #3
    you mean the drive is dead or unplugging it too early causes this issue (and does so often yikes)?
    Diskwarrior I guess I have to go look for that.
    thanks
     

Share This Page