External HD won't read

Discussion in 'Mac Accessories' started by EdgelessLemming, Apr 11, 2010.

  1. EdgelessLemming macrumors newbie

    Joined:
    Mar 20, 2010
    #1
    I've got a simpletech 2tb hard drive which I've used for time machine, but all of a sudden it won't read when I plug it in. I can hear it power on when I plug it in but it won't show up. I've tried plugging in other devices to make sure the ports are still good and tried restarting with and without the hard drive plugged in.

    I've only had this hard drive a week and haven't done any improper device removals to it. Just wondering if there is a fix or if I gotta take it back.

    Thanks

    Also, I am running snow leopard with all the updates.
     
  2. hamlinspahn macrumors regular

    Joined:
    Apr 9, 2010
    Location:
    Oklahoma City
    #2
    1 Week Old

    Since electronics in general fail pretty quickly, like in the first few days to a couple of weeks. I would say take it back as it is likely bad.
     
  3. EdgelessLemming thread starter macrumors newbie

    Joined:
    Mar 20, 2010
    #3
    I just unplugged both USB and power for a couple minutes and tried again and it's working now, thanks.
     

Share This Page