External HDD BU hangs on startup?

Discussion in 'iMac' started by MiniD3, Feb 15, 2018.

  1. MiniD3 macrumors 6502a

    MiniD3

    Joined:
    Mar 9, 2013
    Location:
    Australia
    #1
    Hi Guys
    Sorry about the esoteric title
    Situation,
    I use an external HDD to back up my iMac
    If I leave it attached,
    Close down for the night,
    The following morning when I try to start up, the "little worm" moves across the screen nearly to the end and just stops (hangs)
    I then have to hold the on button down to switch off
    Remove the external HDD
    then I can restart,
    Do my backup
    Then make sure I eject the external HDD and remove it

    Things I have tried
    I have done a first aid check ✔️
    have reformatted the HDD
    done another BU
    plugged in to the other USB slots
    Still hangs

    FWIW,
    I have 2 other drives for my images,
    Images go to one, and then cloned to the other for backup
    I can leave both of these drives attached to the iMac, close down, restart, no problems
    Its only when the BU external HDD is attached, it hangs on startup

    All of the above doesn't appear to have caused any problems except, Its a PITA, when I forget to eject and remove the BU HDD

    Screen Shot 2018-02-15 at 11.36.08 pm.png
     
  2. nambuccaheadsau macrumors 68000

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #2
    You are powering down so nthe external also loses power and unmounts. So what do you think happens on reboot?

    Unmount and disconnect before powering down, or leve the iMac on sleep.
     
  3. MiniD3 thread starter macrumors 6502a

    MiniD3

    Joined:
    Mar 9, 2013
    Location:
    Australia
    #3
    Thank you
    Looks like the only way apparently,
    Gary
     
  4. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #4
    I use a couple of external drives every day which mount / uncounted without problem when I switch my iMac off and on. One is a WD external HDD drive with its own power supply. The other is a SSD drive powered by the USB3 interface itself. I’ve never had any ejection projblems or mounting problems. OSX will unmount the drives on shut down and power off any that are bus powered (I don;t think it maintains permanent USB power when its off).
    Maybe it is a fault with the power management of the BU drive you are using? Do you have a different spare external drive you can try as a backup device, maybe from a different vendor?
     
  5. MiniD3 thread starter macrumors 6502a

    MiniD3

    Joined:
    Mar 9, 2013
    Location:
    Australia
    #5
    Tks for your reply Wardy
    All my External HDD's are WD
    2 are WD 3TB that I use for Time machine BU and just swap them out,
    these are the 2 that make the iMac hang

    the other 2, also WD are 4TB and used for image BU through Adobe Lightroom catalog and dont cause the same problem?

    My routine is to shut the Mac down every few days, it is only then I have the problem when I go to restart
    The new routine is going to be that I eject the offending external HDD for the the time being
     
  6. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    OP wrote:
    "Remove the external HDD
    then I can restart,
    Do my backup
    Then make sure I eject the external HDD and remove it"


    The above "might be your answer".
    Sometimes one has to do, what one has to do, and that's it.

    I generally don't leave external drives connected until I actually need to use them.
    Afterwards, I disconnect them.
    No need to have "too much stuff interacting with the bus" all the time...
     
  7. MiniD3 thread starter macrumors 6502a

    MiniD3

    Joined:
    Mar 9, 2013
    Location:
    Australia
    #7
    That is the way I will be running for the time being,
    Would be nice to know the cause as my friends do not have the same problem
     

Share This Page

6 February 15, 2018