External HDD files disappeared & can't unmount disk.

Discussion in 'macOS' started by martybell, Feb 17, 2011.

  1. martybell macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    Hi guys, been searching everywhere for an answer to this but can't seem to find a solution that's working for me. Sorry if there's another thread the same.

    Basically I was transferring a load of files to my WD 320 GB USB external hard drive (Mac OS X Journaled) when it seemed to just crash in the middle of the transfer. I ejected it & plugged back in and now all my files & folders are missing. Although the files are missing, Disk Utility still seems to have the correct info..

    Capacity : 319.94 GB (319,938,674,688 Bytes)
    Format : Mac OS Extended (Journaled)
    Available : 56.19 GB (56,189,521,920 Bytes)
    Owners Enabled : No
    Used : 263.75 GB (263,749,152,768 Bytes)
    Number of Folders : 2,242
    Number of Files : 59,846

    My immediate though was to repair the drive with Disk Utility but I get a 'Could not unmount disk' message. I can't eject the disk through Finder either. I've tried the lsof | egrep 'MARTY'S' command as mentioned in this thread to see what may be using the drive, but it gives me a huge list of items that don't seem to be associated with the external drive, unlike the result the guy in that thread had got back when he used the same command.

    Any ideas would be hugely appreciated. Let me know if you need any more info. I'm on Snow Leopard 10.6.6.

    I stupidly don't have a backup of a bunch of the files on the drive so could really do without having to format the drive.

    Thanks!

    Marty
     
  2. martybell thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #2
    Went and bought DiskWarrior and attempted to recover with that to no avail. I then made a DW boot disk and attempted to recover from there, but it doesn't see the drive (unlike when I run DW from applications.. weird).

    Any ideas anyone?

    Thanks
     

Share This Page