External HDD mounting issue

Discussion in 'OS X Yosemite (10.10)' started by KsbjA, Apr 27, 2015.

  1. KsbjA, Apr 27, 2015
    Last edited: May 10, 2015

    KsbjA macrumors newbie

    Joined:
    Sep 11, 2011
    Location:
    Europe
    #1
    Original title of post: External drive not ejected properly — permissions error?

    Hi everybody,
    looking for some help here.

    Today, while running late for work, I grabbed my MacBook and accidentally unplugged my external drive (WD My Passport) which I hadn't ejected. Now, when I plugged it back in, it showed the generic grey HDD icon instead of the USB drive icon or Time Machine drive icon. When I opened it, all the files were visible for a second, then disappeared. Finder says I still have my ~300GB of data in the drive, apparently I just can't access it anymore.

    Tried changing permissions, no luck. Can't set it to ignore permissions because of "Error -50". Can't get inside through Terminal because of permissions (and when I try "sudo cd "My Passport"", nothing happens, I stay inside Volumes). Finally, disconnecting the drive (or reconnecting it), doesn't do anything, the disk icon stays on the desktop (can't eject) and I can still open it to see an empty Finder window.

    Help much appreciated!

    UPDATE
    Tried connecting the external HDD to a different Mac. Worked fine. :) Rebooted the MacBook and the stuck hard drive icon went away from the desktop. (I also finally updated OS X while I was at it.) However, when I cd into "Volumes" and do an ls, "My Passport" is still there even though the drive is disconnected. When connected, my HDD works like before, but it now mounts as "/Volumes/My Passport 2", which is admittedly not a major issue (as far as I can tell), but nevertheless something I would like to fix.

    As before, I'll appreciate any help.
     
  2. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #2
    Have you tried ejecting and disconnecting the "My Passport" and then navigating to /Volumes and then deleting the "My Passport" entry in /Volumes?

    i.e.: sudo rm -rf "My Passport"

    It sounds almost like the OS created a new folder under /Volumes but it's a regular folder.
     
  3. KsbjA thread starter macrumors newbie

    Joined:
    Sep 11, 2011
    Location:
    Europe
    #3
    Thanks for the response! Are you sure this is safe to do? I'm always a bit wary of doing "sudo rm -rf", especially in Volumes.
     
  4. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #4
    I'm not really sure the "-rf" is really needed, but the idea is to delete the file link that was erroneously created. If you want to play it save, you could just rename it first, but don't use the phrase "My Passport" in the name. For example you could name it "MyExtDrive" using the "mv" command. Example:

    cd /Volumes
    mv "My Passport" MyExtDrive

    The quotes in "My Passport" are needed because of the whitespace used in the name. You could also escape it as

    cd /Volumes
    mv My\ Passport MyExtDrive

    This needs to be done with the Passport drive disconnected. After it's done attach the external drive and see if it shows up properly.

    After navigating to the /Volumes folder you may wish to check the contents of the new folder you made by typing:

    du -sk MyExtDrive

    -or-

    ls -alR MyExtDrive

    There shouldn't be anything in the folder, but I've seen some rare cases where the OS actually starts putting stuff into that folder, which is actually on your boot drive.
     
  5. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #5
    Try this:
    • Click on "Go" from menubar.
    • Select "Go to Folder...".
    • In the entry field for "Go to the folder:" entry: /Volumes
    • In the finder window that opens, drag the "My Passport" folder to the trash and empty the trash.
     
  6. Laserducky macrumors regular

    Laserducky

    Joined:
    Dec 29, 2013
    #6
    Happened to me once as well. Too lazy to eject WD external hard drive and so just pulled it out. Afterwards, it didn't even detect it.

    Solution was to go to repair disk permissions using disk utility and it got all sorted out : lesson learnt !
     

Share This Page