External HDD Not Functioning - Please Help!

Discussion in 'Mac Basics and Help' started by Condawg, Oct 11, 2008.

  1. Condawg macrumors newbie

    Joined:
    Sep 10, 2008
    #1
    Well, I'm trying to use an external with my Mac.

    It's been working fine since I got the Mac, so I don't see the issue...

    Basically, I have some pictures I wanted to get on my Mac, but I don't have the camera's cable, and my Mac doesn't have an SD slot.

    So, I put the SD card of the camera into my PC (Ubuntu), and then transferred the images to my external.
    I then tried using the external to get the pictures onto my Mac, but it's not showing up anywhere.
    It's freaking weird.

    Anyone know what it could be, and how to fix it?
    I depend heavily on this external... I cannot lose access, and I cannot format it.

    Thanks

    EDIT: Forgot to mention, it IS still functional on Ubuntu.
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    Does it show up in disk utility? You managed to used it with the mac before? And how is it formatted?
     
  3. Condawg thread starter macrumors newbie

    Joined:
    Sep 10, 2008
    #3
    No, it does not show up in disk utility.

    Yeah, I've been using it with my Mac since I got the Mac.

    I'm pretty sure it's FAT.
    Almost positive, in fact, since it cannot hold a file over 4GBs.
     
  4. Condawg thread starter macrumors newbie

    Joined:
    Sep 10, 2008
    #4
    Ahh. A simple restart fixed it.
    /facepalm

    Thanks
     
  5. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007

Share This Page