External HDD slowing down boot... How do I fix this?

Discussion in 'iMac' started by Nirurin, Oct 18, 2013.

  1. Nirurin macrumors member

    Joined:
    Oct 3, 2013
    #1
    Hey guys, got my new iMAc now and, after a fair chunk of playing around and trying to sort out the random annoyances that apple have decided to include, I've managed to mostly get it (and bootcamp windows) all up and running.

    One of the issues I'm left with:

    I have a 3tb external USB3 hard drive. It is always plugged in, and always will be plugged in, as the iMac only has a 250gb SSD, and so the external is my main storage drive.

    HOWEVER...
    When the iMac boots up, instead of booting in a few seconds... it pauses on a blank white/grey screen for 30 seconds or more.

    I have discovered that it doesnt do this if the external drive is disconnected. But this is not an option for the long term. I didnt pay £2000 to have an extra daily annoyance in my life for the next 3 years!

    So I am assuming there is a quick and easy way to stop the iMac from trying to read off the external disk, and instead just boot straight up as it should?

    The solution can not involve physically disconnecting the external drive, as that just means bad design on apples part.

    Thanks guys, hope its something obvious that I've missed!


    On a separate note, and an unrelated problem (so I may make a new thread for this at a later date) :-
    Wired Apple keyboard USB ports in windows. The dont work.

    Or rather... they do work, but are totally unpowered. And so they are unable to run even a standard 16gb usb thumb drive.
    http://www.youtube.com/watch?v=s8kVWy8Qf7A
    This link shows a fix... which doesnt work on the current iMac it seems, as the keyboard doesnt show up in windows as a "generic USB hub". It shows up as a composite device, and a USB2 Hub.

    Any solutions for this would be good too :)
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    I expect that the delay is from the external HDD being asleep and OSx sees there is a connection and waits for the HDD to wake up. The same thing happens when you shut down if the external HDDs are asleep.

    Why is it Apple's fault? They do not make the external HDDs.. Some external HDDs wake up in a few seconds.

    I get around the boot issue by never booting - I leave all Macs on 24/7 except when I go on vacation.
     
  3. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #3
    Its apples fault because there is no reason for the computer to be searching for, or waiting for, external hard drives.

    In a standard PC, I would just access the BIOS, and set the boot sequence to look for the internal disk first and boot. The PC would only look for other disks if there is no bootable internal disk.

    This has been standard for PCs for... I dunno. over a decade definitly. Probably closer to 20 years.

    Unless I ask the iMac to be searching for alternate boot disks (which I can do anyway using the "Option" key during bootup), there is no need for this to be happening.

    It has nothing to do with the manufacturers of the external hard drives.
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    Hi,

    try this :

    In System Preferences / System / Startup Disk, check that the internal disk (the SSD) is selected (no only present, but selected).

    Reboot.

    Example : http://forums.macrumors.com/showthread.php?t=1655428
     
  5. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #5

    I *believe* I already tried this... but now that you specify selected, I'm not sure if I just saw it on the page and assumed it was...
    I'll check this asap and get back to you, thanks

    edit:
    Yes the internal mac partition is selected. The only other option is the bootcamp partition. The external drive isn't even an option.
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
  7. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #7
    Pretty sure this is only if the internal drive is having problems, which it isn't. The boot time is fine with the external drive unplugged, so the problem is that the Mac bios (or equivalent) is searching for alternate boot drives unnecessarily.

    Should be a way to tell it not to do this, like I said normal PCs have had a solution for decades
     
  8. Bruno09, Oct 20, 2013
    Last edited: Oct 20, 2013

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  9. Chippy99 macrumors 6502a

    Joined:
    Apr 28, 2012
    #9
    And to be clear, it's not normal behavour. I have 2 large external drives attached via USB3 - one holding all my data and the other for Time Machine - and booting is rapid and without pause whether the drives are attached or not. Cold boot or reboot, it's still fast and no pauses.
     
  10. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #10
    Same here : one external disk for Time Machine, another one with 7 partitions for datas and other OS.
     
  11. Asrath macrumors newbie

    Asrath

    Joined:
    Oct 8, 2013
    #11
    In System Preferences you can choose a drive to boot from. Sometimes if none has been chosen, there can be a delay.
    Give it a try an select your internal drive there.
     
  12. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #12
    See posts #4 and #5 .........
     
  13. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #13
    That guide shows how to reset the PRAM, not the NVRAM.. Which did you mean for me to try? I can always do both, assuming its safe to.

    I can't see any reason why my drive would be having this issue. I've not made any changes t the new iMac, beyond installing boot camp. The drive is a buffalo drivestation velocity, which is a good quality 3tb USB3 hard drive, but has no special features that could cause this.

    The only difference I can see is that its formatted to exFAT, instead of macOS extended. Has to be this way cos I will need the data available for both windows and osx.
     
  14. Bruno09, Oct 20, 2013
    Last edited: Oct 20, 2013

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #14
    NVRAM and PRAM are the same thing, see here :http://support.apple.com/kb/HT1379

    It is not an issue of the drive : the NVRAM is a little file which contains some infos, among them : which disk to boot from.

    Resetting the NVRAM, thus creating a new file, will make sure that the Startup Disk info you set in System Preferences is actually taken in account.
     
  15. LowVoltage macrumors newbie

    Joined:
    Feb 7, 2013
    #15
    I don't know if this is relevant at all, but I've seen some odd things with boot times as well on my Mac Pro in a similar situation.

    I have a Mac Pro connected to a Lacie DVD-R drive via Firewire 400 (FW, by the way, is the only connection available for this drive... I didn't want to use up another USB port, it's faster anyway, and it was on sale). If I power off the drive at its switch but leave the cable connected, upon start up my Mac Pro sits there for maybe one to five minutes (never officially timed it) with a gray screen. There is no hard drive activity sounds to be heard. Disconnecting the FW cable jogs the computer out of its stupor and starts normally. Because I don't frequently use the external DVD drive I normally leave it turned off at its power switch with the FW cable unplugged, although I have forgotten this procedure already and the start up peculiarity leads one to panic.

    I've never brought this up with the folks at the Apple Store as it's an avoidable situation and not critical to normal functions. However, I have wondered at this behavior. I know it's not the exact same hardware as the OP, but the symptoms are awfully similar.
     
  16. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #16

    Actually I do also have a Samsung bluray writer plugged in, but I don't think its involved with the problem.. The problem fixed when the HDD isnt plugged in. Unless its something to do with which USB port is being used..... But that seems unlikely.

    When I get home I'll try resetting the nvram and see what happens :)
     
  17. LowVoltage macrumors newbie

    Joined:
    Feb 7, 2013
    #17
    Just to be clear, it wasn't so much the optical drive that concerned me, it was the properties of the connection. In the case of Firewire, without being too specific, the connection can provide more power to a device in addition to the various bandwidth advantages the Firewire standard has over older USB versions (2.0 and older).

    Now, as I understand it, USB 3.0 is now a lot more similar to FW in terms of bandwidth saturation, and without going over every last detail of the specification, I'm quite positive USB 3.0 can provide more power to various devices like external hard drives, optical drives, and so on. I mention this to contrast that standard over, say, certain portable hard drives that use USB 2.0 but need two connectors plugged into the PC to provide the device with enough power to operate without a dedicated DC plug.

    Considering my history with the weird behavior of my Lacie DVD drive, before you even posted your own lament I've had plenty of time to kick the idea around: Perhaps in both our cases the connection (FW and USB3) standard allows for some kind of recognition of the device, yet not sufficient enough to let the OS/bios/whatever discount the item as a proper startup volume. This may also involve certain chip sets in our respective devices.

    I'm holding my hands up here and fully admitting I'm not savvy enough to be referencing exact specifications or standards; I only know enough to be dangerous! I've used plenty of PCs and am aware of the fact that one can set the bios to go through connected drives in a particular order to find the OS volume. I'm not sure, though, this is necessarily an issue of the Mac trying to find the proper OS volume. Rather, the Mac just doesn't know how to... interpret (?) these connected devices. I probably sound like an apologist, but I'd imagine if the problem were more wide spread we would see it addressed. Perhaps with the advent of more iMacs using USB3 and the ubiquity of likewise-connected external hard drives we'll see something discretely implemented in OS X...
     
  18. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #18

    I think the problem with this is that it is actually a fairly common problem... I have found a few other posts on the internet about this issue, but none have had much in the way of helpful responses.

    Peoples reactions to it are to simply unplug the drive during boot up, or to never turn the Mac off in the first place.

    However I just see this as fanboys making excuses for a flaw in an Apple product. "Unplugging the drive" is not a valid answer.

    However, I still need to try resetting the nvram (have been busy with work) so hopefully that will be the answer!
     
  19. LowVoltage macrumors newbie

    Joined:
    Feb 7, 2013
    #19
    I hope you have luck with resetting the nvram. I never mentioned this previously, but it just so happens I have an OWC Mercury Elite Pro as my Time Machine drive connected over FW800. Since I use it fairly regularly I never unplug any of the cables, but I do power off the drive at its switch. Weirdly enough, this poses no problems on startup, unlike my FW400-attached Lacie DVD drive. I don't know if that blows away my earlier theory or can be discounted because of some inherent difference in the FW800 standard, or as noted before, a difference in chip sets in each device.
     
  20. Jedi Master macrumors regular

    Joined:
    Apr 5, 2013
    Location:
    ar the moment on the Death Star
    #20
    Best of luck


    Must be why the pc world is switching over to efi finally
     
  21. Nirurin, Dec 1, 2013
    Last edited: Dec 1, 2013

    Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #21
    Well, after a few weeks of this seemingly being a fixed problem, it has now returned, with a vengeance.

    I have had the drive plugged into a USB hub for the last few weeks, and it has been behaving. I didnt realise this might be related at the time, not even sure how it could have been.

    But today I ran some speed tests, and found that the read speed of the HDD in the hub was only 30mb/s. The read speed of the HDD when in the iMac USB port directly is over 150mb/s. So something is clearly wrong with the hub.

    So I now have the HDD plugged into the iMac rear ports directly.


    BUT...
    Now, instead of a 30 second boot time, its more like 2 minutes. If not more (i should actually time it i guess, but its long enough for me to look up solutions on my phone before the login screen pops up.)

    I have reset the PRAM and wiped timemachine off the drive totally in case it was the recovery boot interfering, i have reset all permissions for the drives (internal and external).

    If the drive is not plugged in, the computer boots fine. But this isnt much of an option, as the USB ports are round the back of the iMac and the drive lives far underneath my big desk and isnt reachable.

    And putting hte mac to sleep instead of shutting down isnt an option, because I use bootcamp. And the long boot time happens *before* the point where the drive selection screen pops up to select windows/osx. So even loading windows is a chore.

    Really no idea why this should be doing this. The drive itself is totally blank, and shouldnt have this issue.

    Last resort is to return the drive, and attempt to find another one that the mac hardware/software can actually cope with. So if anyone has a recommendation? It has to be at least as fast as this one:

    Buffalo Drivestation USB3
    Read: 150mb/s
    Write: 175mb/s

    and also reliable and not stupid expensive.

    Thanks again, this has been a real pain in the neck.

    edit:
    Boot up time wth HDD plugged in is over 2 minutes to reach the first log in screen. Then it goes onto the grey screen with the apple logo for another minute or so before actually showing desktop.

    Edit 2:
    Re-tested with the HDD plugged into the USB Hub. Boots up at normal (quick) speed. The drive still spins up, but it isnt slowing down the boot time.
    Even though the USB hub is actually a huge slowdown of read and write speeds, so the problem cant be anything to do with the iMac attempting to read anything off the drive, cos it being plugged into the hub should make this worse not better in that case.

    Completely illogical.

    Edit 3:
    This time I tried to run the Verbose mode on bootup, to see if any error messages pop up during the boot. The screen was blank and grey (no 'verbose' messages) for the entire 2 minutes before the login screen. Then after I log in, it then starts the verbose script.

    I assume this is due to my login screen being earlier than usual, as I have the FireVault on, so my login comes before the loading sequence for OSX.

    However this just makes the problem even more confusing, because it means the mac is hanging on the drive before it has even attempted loading OSX. And it doesnt hang when the drive is on a slow USB hub connection.

    I have tried it in several different USB ports (no effect).

    I have tried setting the internal drive as the startup drive (about 10 times now, its always been selected but everyone keeps saying thats the win-all solution. It isnt.)

    The external drive seems to be working perfectly.

    Stumped.
     
  22. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #22
    Apparently an unfixable problem on macs. Strange seeing as PCs have solved this problem decades ago.

    Unhappy.

    Gonna try and replace the hard drive with another model and hope that the Mac doesn't throw another hissy fit.

    /end
     
  23. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #23
    It'd Apple's fault because your machine behaves differently to the standard way?

    You clearly have some sort of bug or conflict here. All your crowing about how this was fixed "20 years ago" on the PC just makes you sound antagonistic. It was fixed "20 years ago" on the Mac too - what you are experiencing is clearly abnormal boot behaviour.

    The Mac will boot from the selected partition (set with System Prefs instead of the Bios, but achieves the same thing), and not hang on for other drives unless the selected boot partition cannot be started for whatever reason (usually because it's corrupt or failed etc). Then it will begin looking for other boot options.


    Whatever is going on with your USB drive is clearly causing a conflict with the POST or some other part of the startup procedure, given that it is happening very early in the boot sequence.

    It may very well be Apple's fault - a bug in the EFI firmware, for example, or it might be the fault of your drive.

    What happens if you boot when the drive is awake? Reboot right away with the drive spun up if at all possible.
     
  24. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #24
    From the HDD speed when plugged into the hub, it looks like those are USB 2 speeds. Is that a USB 3 hub?

    There should be no delay when a USB HDD is plugged in through USB, unless there are files needed on that drive for boot up. Are you keeping any files such as a user Home Folder on that drive? It has to be looking for something that it thinks it needs on that drive.

    Your situation is not normal. On our Late 2012 iMac with internal fusion drive, it takes about nine seconds to boot up with a WD USB 3 HDD, and a Seagate Thunderbolt HDD connected.
     
  25. Nirurin thread starter macrumors member

    Joined:
    Oct 3, 2013
    #25

    The hub is *meant* to be USB3, it is advertised and labelled as such, but that is a seperate issue that I am dealing with at the moment.

    Also there are no boot files at all on that USB drive. It used to have a partition for timemachine on there, but I have deleted that in an effort to resolve this problem.
    The only files on there are video files and documents, no system files.


    As for what Joe asks, the delay in boot time happens wether I do a cold start of the machine, or if I restart from desktop. Either way, it takes a couple of minutes to boot.

    If I hold option when booting, the selection screen for the mutliple drives (bootcamp etc) does not come up until the end of the intitial 2-3 minutes of blank grey screen.

    I am antagonistic because I do not expect this sort of issue to happen on such an expensive machine. It is vaguely possible that the USB HDD is causing this problem, but as it has been totally formatted and it just a plain old 3.5" HDD in a USB enclosure there is no way I can see that it is causing the issue. The drive behaves flawlessly within OSX itself when being used, and does not have this issue when tested on a standard PC laptop (the only other machine I had available).

    I am looking into sourcing a replacement HDD, just as an option of last resort, and will have to hope that I pick a hard drive that the mac can cope with
     

Share This Page