External HDD suddenly not recognised

Discussion in 'Mac Basics and Help' started by AmbaGambla, Jul 10, 2011.

  1. AmbaGambla macrumors newbie

    Joined:
    Feb 20, 2009
    #1
    Please help!

    I bought a WD 250gb external HDD last 9 months ago, and it has been working fine. I do stuff on my mac at home, take it to work and do it on my PC there. No problems.

    Suddenly this week nothing happens when I plug in the HDD. I have tried it on about 8 different computers (PC and Mac) but nothing. I tried my boss's cable and nothing.

    I have tried using SpinRite and DiskWarrior, but because the HDD is not detected these seem to be of no use. The IT guy at work suggested a shorter cable or one with more power, so I have ordered one of each from ebay...

    What else can I do?? I need the stuff from my HDD. Sometimes when I plug it into a PC I get the message that 'this USB device can not be recognised' - so I know that it knows it is there (does that make sense!?)

    Please Please Please can anyone help me!?
     
  2. sleinad macrumors member

    Joined:
    May 11, 2011
    #2

    I also have a WD external drive, and I know that after a year and about 5 months it just got corrupted. There was nothing you could do, the hard drive died. (Not physically, but the data on it was just erased) Hard drives aren't perfect, so sometimes things like these happen.
     
  3. AmbaGambla thread starter macrumors newbie

    Joined:
    Feb 20, 2009
    #3
    The drive is spinning and not making any unusual noises. The lights are on but there's nobody home so to speak.

    Does it seem like I've lost the lot? I think I backed it up about 2 months ago, but it's still a right royal pain in the @ss
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    I don't know if Western Digital's behave this way or not, but based on what I've read about other drives, if it's a desktop model it could be a bad power adapter.
     
  5. ThatNukkaMoe macrumors newbie

    Joined:
    Mar 17, 2011
    Location:
    North Carolina
    #5
    The Straight Answer is: Western Digital sucks! Don't use them. I prefer Seagate, never had a problem with them.

    I have a Western Digital 750GB External Hard Drive that had numerous problems with my MBP and other Macs. When I bought the Western Digital (it was brand new). No problems from the start. After a week or so, the Hard Drive wouldn't mount. I tried numerous times to remount, restart the computer, unplugging, different cables and all the troubleshooting process from every thread I could find. (Tried on a Windows computer also) So I gave up and formatted the Hard Drive. (Did a Zero Out data and One Partition ex-fat) The second time, all the files were gone. I tried to recover the hard drive, but the files were corrupted and un-recoverable. The third time, half of the files was missing. I tried showing hidden files, looking at every folder to see if I misplaced it. Nothing! Went to Disk Utilities and it said the hard drive needed to be repaired. Gave up on this Hard drive, "might be defected or something" I said to myself, so the same day I bought a Western Digital 500GB External Hard drive because it was on sale. Same problem with this WD External HD! Within two weeks, wouldn't mount, keep the files, or due its duties to serve humans. One of my colleagues has the same brand and model WD External hard drive. He said all the things I mentioned. Manual re-mounts, never mounts, files missing or corrupted, and re-format the hard drive numerous times
    Many forums do not recommend WD External HD. They used to be good, like back in the 90's and 2000's. (My personal Opinion)

    So my recommendation to you is, don't use this brand. Things like trying another cable won't work. (Just wasting time and money) Some people say it works; some others say it won’t. Why go thru all the trouble?
     
  6. bibkel macrumors newbie

    Joined:
    Jul 11, 2011
    #6
    seagate

    sooo, I had a similar issue with my WD so I got a GoFlex Seagate. I am trying to open iPhoto using option, choose other Library and then I am stuck. I have "external storage' but it won't "open" so I am unsure what I am doing wrong.

    Apple store is who suggested this so I can delete the pictures that take up most of my hard drive in my laptop macbook 13". Alias Source is what he called it.....but I find nothing helpful so far. Can you help? you seem to be knowledgable about Seagate, and this is my first one.
    Got it yesterday and backed everything up and started Time Machine. It took forever, all night and most of today, but now I cann't access what is in it.

    Any help is appreciated thanks.

    I am inexperienced with Mac's.
     
  7. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #7
    If the drive is spinning and you're getting messages like "This USB Device is not recognized" vs. messages telling you the disk is not initialized or formatted... it's possible the electronics on the drive are failing. A bad USB cable is not impossible although I've never personally witnessed that cause the problem you're having.

    Here's a Catch-22 for you. The drive is probably under warranty (I'm guessing a 1-year deal). Your data may be salvageable if you put the drive into another external drive cage, but cracking the WD case open will void your warranty.
     
  8. Gibsoni macrumors newbie

    Joined:
    Mar 25, 2008
    #8
    I had the same thing with a 2 or 3 year old WD external HD. It just stopped being recognised by all computers.
    I solved it pretty easily by buying a cheap new casing for it from ebay. I took it out of the original WD plastic casing and fit it into the new one, it still works like a dream and all fixed for under 10EUR I think.
    I understood that the internal socket of the original casing had broken (could have been knocked at some point). I just plugged the HD into the socket of the new casing and hey presto.
    Happy days.
     

Share This Page