External keyboard + Modifier Keys NOT working

Discussion in 'MacBook Pro' started by neenja, Aug 1, 2011.

  1. neenja macrumors 6502

    Joined:
    Jul 17, 2008
    #1
    Just got an external Logitech K320 Wireless Keyboard (with unifying usb dongle)

    As most of us know, the ALT key and WINDOWS key behave in a swapped manner when it comes to mac keyboards.

    I want the ALT key to act as the COMMAND key and the WINDOWS key to act as the OPTIONS key.

    I go to system pref, keyboard, modifier keys, select the correct keyboard in the drop down (unifying device) then set as needed. After pressing ok, nothing works, it is still defaulted. I go back in, check that the settings are correctly changed, and they are.

    I also tried to test the internal keyboard while the unifying usb is plugged in. I make the changes to internal, press ok, then test. Nothing.

    The only way to make the modifier key changes to actually work, is to unplug the unifying usb dongle, make the changes (I am only able to select the internal keyboard) and save. Test, and the changes actually work.

    For some reason when I have the unifying usb dongle plugged in (directly in yes, not into a usb hub) it will show settings get saved, but the changes dont actually happen.

    This is insanely frustrating, I've searched all over, tried deleting plist files, nothing works.

    Any ideas?
     
  2. neenja thread starter macrumors 6502

    Joined:
    Jul 17, 2008
    #2
    Hmmm, just realized that when I restart, the Unifying Device keyboard setting goes back to default.

    :confused::confused::confused::confused::confused:
     
  3. neenja thread starter macrumors 6502

    Joined:
    Jul 17, 2008
  4. neenja thread starter macrumors 6502

    Joined:
    Jul 17, 2008
    #4
    I gave up. Ended up getting KeyRemap4MacBook and that did the trick.

    Pretty silly how we have to use a 3rd party program to do something that OSX has an option for, but is broken.

    Sigh.
     
  5. plochner macrumors newbie

    Joined:
    Feb 21, 2008
    #5
    Ran into this same frustrating problem myself today. After every reboot, my swapped Option and Command keys revert back to normal. Also, in the "Select Keyboard" dropdown, I'm now seeing multiple copies of both my mouse and keyboard listed in there.

    Aggravating. For this and various other reasons (including the horrible active directory integration problems) I'd reinstall SL if I could, but my new MBP shipped with Lion so I'm stuck with it.:mad:
     

Share This Page