External keyboard problems with mojave

Discussion in 'macOS Mojave (10.14)' started by richeze, Oct 30, 2018.

  1. richeze, Oct 30, 2018
    Last edited: Oct 30, 2018

    richeze macrumors newbie

    Joined:
    Oct 30, 2018
    #1
    Hi,

    Have had this since release, but hoped 10.14.1 would have fixed but didn't. I am using a MacBook Pro mid 2012 with an external apple wired keyboard. Since Mojave most of the keys in the top row no longer function, togther with the page up down, cursor keys and media keys
    I have tried a second identical apple wired keyboard and have had exactly the same experience.

    Just tried a normal cheap pc keyboard and all the media keys function properly, page up down etc.


    Anybody else have this problem?

    Thanks
     
  2. richeze thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #2
    Just tried with a 2nd MacBook Pro (late 2014) and another wired apple keyboard and had same issue. Going to try with a different apple keyboard tomorrow
     
  3. pixelmix macrumors newbie

    Joined:
    May 23, 2017
    #3
    I have an old Apple bluetooth keyboard (the short one) and find that occasionally the function keys do not work. Toggling the below option in the System Preferences "Keyboard" page seems to get it working again.
     

    Attached Files:

  4. richeze thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #4
    Thank you for your reply. I had already tried that but appreciate the help. I am sure its a Mojave issue, as I have gone back to high Sierra and everything is working great again. I have raised a bug report with apple, but not holding my breath, probably will try a newer keyboard and see if that fixes the problem
     
  5. rvxd macrumors newbie

    Joined:
    Jan 22, 2019
    #5
    After updating to Mojave 10.14.2, my Apple USB keyboard only works with an extension cable. Does not work if connected directly to MacBook Pro (15-inch, Mid 2012).
     
  6. richeze thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #6
    thanks for reply. never tried with extension, just bought a new wireless keyboard
     
  7. jurbain81 macrumors newbie

    Joined:
    Apr 15, 2019
    #7
    I confirm the same problem here with a corded Logitech Wave keybaord. Until Mojave it was working perfectly. Now on version 10.14.4 (18E226) the top row refuse to input upper case letter. All the other one are working as expected, top row works with lower case but no luck as soon as you hit **** + letter of the top row.

    I also report it as bug to Apple, wait and see
     

Share This Page