External monitor issues with MBP

Discussion in 'MacBook Pro' started by RedRed99, Dec 25, 2011.

  1. RedRed99 macrumors newbie

    Joined:
    Nov 15, 2011
    #1
    So i picked up a HP x2301 monitor a few days ago to connect with my macbook pro, has been running well since, had no issues setting the thing up. It's an early 2011 15inch mbp, with the thunderbolt connection. I'm using a mini-displayport to HDMI adaptor, and then a HDMI cable to connect to the monitor.

    However, a few hours ago, i left the room for a short while and came back to find the monitor unresponsive, and that it wasn't regestering the HDMI connection, even though the macbook was regestering it (the screen on the macbook flickered when i connected the monitor, i could access all of the callibration and resolution settings when it was plugged in as if it were connected fine), but still no picture, the monitor fails to pick up the HDMI signal. I've tried unplugging, replugging, changing the HDMI cable etc (don't have a spare mini-displayport to HDMI), but no change. I even ran windows 7 under bootcamp yet the problem still persists.

    I suspect that the adaptor has died for whatever reason, but then why would my macbook still register the monitor as if there was no problem at all?

    I've fiddled with the display settings but still can't resolve the issue

    any suggestions?

    Thanks in advance




    ---------------------------------


    Early 2011 15.4" Macbook Pro 8,2
    2.0 GHZ intel i7
    4GB ram
    Ati Radeon 6490m with 256mb V/ram
    intel hd3000
    osx Lion and Windows 7 ultimate x64
     
  2. TheIguana macrumors 6502a

    TheIguana

    Joined:
    Sep 26, 2004
    Location:
    Canada
    #2
    Are you using gfxCardStatus to manually force your MBP to use the integrated graphics card?

    If so when using an external display on your Mac you have to make sure it is letting it switch over to the dedicated graphics as the integrated Intel graphics is not able to output to the Thunderbolt port.
     
  3. RedRed99 thread starter macrumors newbie

    Joined:
    Nov 15, 2011
    #3
    Thanks, issue resolved, i turned off automatic graphics switching and now it's working again.
     

Share This Page