External monitor over Mini-DP -> DVI, does not always reset ??

Discussion in 'MacBook Pro' started by TheHoff, Nov 1, 2008.

  1. TheHoff macrumors 6502

    Joined:
    Oct 22, 2008
    #1
    Computer: Aluminum MBP, 2.4, 4G RAM, 320 Gig HD
    Monitor: Samsung 244T at 1900 x 1200
    Connection: Apple Mini-DP -> DVI cable

    Everything is configured properly as the first time I turn the monitor on and plug in the MBP, it comes up fine. It does a strange static that I've not seen before as the connection is warming up but then the screens appear and the two monitors work as normal (the MBP screen and the external).

    The problem comes when the MBP goes to sleep. Once it is woken up, the external monitor rarely comes back. It will either stay blank or it will cycle on and off like it has the wrong refresh rate set. If I unplug the cable, wait a moment for the MBP screen to take over, and then plug the external monitor back in, it does come back just like it was plugged in the first time.

    Anyone else have this where their external monitor doesn't come back correctly? It always did under Vista; never had this issue with the old laptop so I don't think it is the screen. Maybe it is the adapter? Or the MBP itself?
     
  2. tylerma macrumors newbie

    Joined:
    Oct 30, 2008
    #2
    SAME THING here on a Dell 27" screen, and what a pain in the neck.

    I have found a little workaround though. Assign one of your corners in Expose to 'Sleep Display'. If you wake up your mac and the external screen does not come on, put the mouse in the corner to put it to sleep again and re-wake it up. Usually comes back on for me after 1 or 2 times.

    I know, not a solution by any means, but it beats unplugging/replugging while we wait for an update...
     

Share This Page