External NTFS drive missing content! NEED HELP PLEASE!

Discussion in 'Mac Basics and Help' started by Roostafari, Mar 12, 2010.

  1. Roostafari macrumors newbie

    Joined:
    Mar 12, 2010
    #1
    Greetings Folks!

    First post and very new to macs.

    I just got an imac and love it so far. Have been a pc user (and still am) and have a western digital external drive with crazy info on it that I got running on my mac without having to format it to fat32.

    Everything was working perfect up till last night and now I can't access any of the contents on the drive.

    It seems that everything is there as the drive only shows 62GB of 500GB free but the folder is empty. :(

    I tried to run a disk repair using disk utility on my mac but everything is grayed out. I also tried to run a disk check on my pc but windows cant seem to access the drive without wanting to format it first.

    Desperately need some advice.

    Thanks in advance!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    This is something you should be fixing from a Windows computer, not a Mac. Mac NTFS support is very limited, and I don't know of any Mac utilities that will even touch an NTFS drive.

    As for how to fix it, I'd ask in a Windows forum somewhere. I don't know much about Windows utilities.

    Oh, and welcome to Mac/MacRumors. :)
     
  3. Roostafari thread starter macrumors newbie

    Joined:
    Mar 12, 2010
    #3
    I tried there first. I cant even open the drive or access it in anyway from a pc. On my mac, the drives recognised and I can open the root folder. Sadly there aer no files or folders in the root as there should be but I can deduce that they are still there bc the free space is what it should be.

    I am fluent in windows and have exhausted all possible avenues to get the drive to work on a pc. Am thinking this can only be fixed somehow on my mac.
     

Share This Page