external SSD not mounting unless on hub ???

Discussion in 'macOS Sierra (10.12)' started by Gdeschodt, Jan 30, 2017.

  1. Gdeschodt macrumors newbie

    Joined:
    Dec 9, 2014
    #1
    Weird one, wondering if others have a fix... I got an external SSD to use as an experimental boot drive to see if it would speed up my aging Mac Mini (why not internal? disassembly is quite involved vs 3 seconds to plug in an external, and if this did not work well - I'd have a spare external drive that way to use for time machine)

    Here's the odd thing: The drive won't mount when plugged into the Mini directly. Disk utility would not see it. Flat out does not exist (it gets power). Tried all 4 good ports..

    But when plugged into a USB 3.0 hub, itself obviously plugged into the mac (on any port), the disk mounts A-OK. I was able to format it, install OSX, restore from time machine, boot from it... Still not mounting when plugged to the mac though ! Boot fine on hub. Rotated ports, nothing doing..

    Since I had computer time between the time-eating fantastic Australian open and the Daytona 24, I started over using carbon copy instead to clone my boot drive onto the SSD... Perfect... Booted from that on the USB hub, identical boot, all good. Tried booting from it connected to the mac, does not exist... Amazing..

    And yeah there's a samsung drive mount tool that comes with the drive, I installed it and updated it, nothing... Samsung T3 500 gig... Apparently this happens to other folks. Wondering why !
    I'm desperately trying to keep that mini going until apple has the "courage" to consider releasing new desktops, hopefully before 2020 ;-)
     
  2. StuBFrost macrumors member

    Joined:
    Apr 1, 2016
    Location:
    Manchester, England
    #2
    The obvious question is whether the USB hub is powered off the Mac or whether it has it's own power supply. If off it's own power supply then that is the difference. If off the Mac, then it still sounds like a power issue of some sort.
     
  3. Gdeschodt thread starter macrumors newbie

    Joined:
    Dec 9, 2014
    #3
    USB HUB is a tiny 4 port thing with no external power, just whatever it gets from the USB connection to the mac. So if it works from THAT, it should work from the mac directly. For that matter the SSD drive has its own power anyway, so I don't believe it's lacking... It's gotta be some bug that lets it be seen under a hub but not directly - don't know enough about USB's inner workings to make sense of it... End of the day I can work it this way without a huge perceived speed issue, but it's just so damn weird !!! Shouldn't have bought Samsung, I understand there are issues with those - despite its built-in enclosure being compatible to all standards, I checked before I bought...

    In parallel, I'm questioning my decision to use an external SSD/USB solution.. Seems a little less stable overall, occasional app crash or screen color change, all reset with a reboot, not happening when booting from the internal drive. SSD may be too flaky for me - don't think it's defective as others have experience this.... Faster but flakier...
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    OP:
    I didn't write what follows.
    I saw it posted over at macintouch.com, and archived the post.
    It may, or may NOT be useful to you.

    Here it is:
    =========
    mconnally
    I recently had occasion to try to startup my wife's MacBook Pro running 10.12.3 from an external startup disk attached by Thunderbolt-Firewire to a Freecom SATA disk dock. Holding the Option key at startup resulted in the expected list of startup disks but did not include the external drive. However, the disk is included in the list of available startup drives as shown in System Preferences/Startup Disk, and the system will boot from that disk when selected in that fashion.

    Trying the same exercise on my Mac Pro running 10.11.6, connected by Firewire to a Wiebetech SATA disk dock, with a good startup disk inside, resulted in the same thing. The startup disk is not seen by Startup Manager when holding the Option key down at boot time. It is seen by the Startup Disk preference pane, and will startup from there when selected.

    It seems that this situation was brought about recently by Apple introducing a security feature inhibiting Startup Manager from seeing external devices using Option ROM firmware. For a workaround see:

    https://support.apple.com/en-gb/HT202796

    You can disable that behaviour by issuing the command:

    sudo nvram enable-legacy-orom-behavior=1

    You can reenable it with the command:

    sudo nvram -d enable-legacy-orom-behavior

    Or from the Startup Manager screen, you can press Option-Command-Shift-Period to make the Option ROM device visible.
    =========
     
  5. Gdeschodt thread starter macrumors newbie

    Joined:
    Dec 9, 2014
    #5
    Thank you, sounds worthy of a try ! Exactly the type of info I was looking for, win or lose ;-)
     
  6. Boneheadxan macrumors regular

    Boneheadxan

    Joined:
    Jul 19, 2009
    #6
    I have this issue on my 2013 MBP. Few of my portable hard disks don't read until hooked up to a hub. There are times after plugging in and out multiple times it will eventually show up.

    Going to try the fix mentioned above.
     

Share This Page