External USB drive ejects itself

Discussion in 'MacBook Pro' started by Mac-Tim, Apr 11, 2011.

  1. Mac-Tim macrumors newbie

    Joined:
    Oct 7, 2009
    #1
    I just bought a portable WD My Passport 1 TB hard drive because I travel for business and I want to carry around some large data files (virtual machines) that don't fit on my Late 2008 model MBP's internal disk. I formatted it (mac journaled) just fine. The drive seems to work okay while I'm writing to it, but now, just a couple of minutes or less after I plug it in each time, it powers down and ejects itself (ie, is no longer listed in the Finder).

    I opened a terminal window and changed directory to the disk (so that it would appear busy since the shell has it in its current working directory) and then it won't power itself down but about every 60 seconds I get the following message:

    WD My Passport 0740 Media is in use and cannot be powered off.
    Try quitting applications and trying again.

    The messages stack up until acknowledged so I could potentially have hundreds to click through if I left it that way. Needless to say, this problem is causing the drive to be useless.

    I have a 2 TB WD USB hard drive at home that I use for Time Machine backups and I haven't had any problems with that one at all. I've left it plugged in for a couple days at a time while home.

    Is this a hardware problem with the HDD or a Snow Leopard OS problem? I need the space for a large work project and this is preventing me from moving forward.

    Thanks.
     
  2. frankieboy macrumors regular

    Joined:
    Jun 29, 2009
    #2
    Suggest you make a warranty claim on the drive.
     
  3. Mac-Tim thread starter macrumors newbie

    Joined:
    Oct 7, 2009
    #3
    Okay, that's one opinion. But does anyone have any actual experiences similar to this behavior? Obviously I can just go exchange it, and I was planning on doing just that at the conclusion of my current trip, but I'd like to hear from anyone who has some actual, real-world experience with this same problem.

    Thanks.
     
  4. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #4
    Is it possibly a green drive and powering itself down for power savings, as that is what it sounds like to me? I am not sure if power saving mode can be turned off, but I have heard of people having this issue when using green drives for time machine, as when TM isn't using the drive, they power down and then next time TM goes to use them they have been ejected (due to the powered down state).
     
  5. hitech4pg macrumors newbie

    Joined:
    May 20, 2011
    #5
    Time Machine

    I had the same problem, just a shoot in the dark I initialized Time Machine as the back up (I have a Passport SE 1TB) I haven't had the error message pop-up since.

    Hope this helps.
     
  6. spelman macrumors newbie

    Joined:
    May 21, 2011
    #6
    You must be right, all sign tells me that this is a driver problem, not a problem with the disk itself.

    Anyone had any luck?

    I have a newly bought WD 1TB, and to begin with it worked, after installing the WD Smartware app and reboot I have problems, and I am convinced WD Smartware installer installed a driver for this - Turbo or similar - can that be the problem?

    How do I uninstall such a driver again?

    Thanks
     
  7. hitech4pg macrumors newbie

    Joined:
    May 20, 2011
    #7
    Unistalling Driver

    WD has a "Uninstaller" once I uninstalled the software I haven't had the problem. I also turned of Time-Machine, things are working perfectly.
     
  8. friendlyhiker macrumors newbie

    Joined:
    May 27, 2011
    #8
    Sleep Timer

    I was just talking with WD tech support (also had a time machine problem, which may have related to energy saver settings on the Mac).

    I asked about this "cannot be powered down" error. I had same problem after installing Smartware 1.3.3.6. It went away when I uninstalled it. But the tech support guy said Smartware has a sleep timer, and he believes the problem comes from the sleep timer trying to kick in when other things are going on. So check the sleeptimer settings in Smartware.

    Still not sure that's the answer. My Smartware sleeptimer was set by default to Never.
     
  9. carltardif macrumors newbie

    Joined:
    Sep 2, 2011
    #9
     
  10. axa macrumors newbie

    Joined:
    Apr 18, 2012
    #10
    SmartWare

    I had the same problem with my disk.
    A bunch of "WD My Passport 0740 Media is in use and cannot be powered off.". Disk ejecting itself etc.

    Uninstalled "smartware" = fixed it!
    Not so smart ware...
     

Share This Page