External USB drive won't mount on Macbook Pro LEFT side

Discussion in 'Mac Basics and Help' started by steeler, Jun 15, 2008.

  1. steeler macrumors regular

    Joined:
    Jan 30, 2008
    #1
    I have an external USB enclosure by ICYDOCK and a Santa Rosa Macbook Pro. The hard drive is a 120 GB Hitachi and is formatted as "Mac OS Extended (Journaled)".

    When I attach the USB connector to the USB port on the left side, it won't mount. When I attach to the USB port on the right side of the MBP, it mounts and works just fine. Verifying the drive turned up no issues.

    I've also used a Wacom tablet on the left side and had no issues. I don't remember using anything else on that left USB port.

    Anyone know what might be wrong or something I can do to try and fix this? It's not a huge deal at the moment, but I would like to be able to use both USB ports to their full potential.

    Any help is appreciated. Thank you.
     
  2. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #2
    The left USB port does not have the same power output as the right one. Because of this, certain USB devices won't work on the left. Mine does the same thing.
     
  3. steeler thread starter macrumors regular

    Joined:
    Jan 30, 2008
    #3
    I wasn't aware of that... very interesting. Thank you!
     
  4. billmister macrumors 6502

    Joined:
    Sep 15, 2007
    #4
    Maybe i'm to late but i have just witnessed this tonight. I get home and attach my digital camera to my left side MBP and nothing... so i'm thinking what happend maybe the 10.5.4 updated messed something up. So then i plugged it into the right side and everything works fine?!?!?

    So then i plugged in my iphone into the left and it worked, also worked into the right. But my digital camera only works on the right side.. I'm thinking your right.

    Man i'm happy i searched, i was starting to freak out i had a bad MBP. I baby my MBP so much.. That's good to hear.

    So it's not usb 1.0 is it?.. it's still 2.0 obviously if it takes my iphone but just weaker power?
     
  5. billmister macrumors 6502

    Joined:
    Sep 15, 2007
    #5
    well what's weird about it is, i restarted my computer... then i tried pluggin in the same camera on the left side and it works now. Hmmm it's weird.

    I think the 10.5.4 update must of done something because after the update the computer restarted itself with my iphone connected to the usb on the left side... and when my mbp wasn't detecting my camera from the left side i clicked on iphoto and i saw iphone under devise. So i don't know what that was about?... every time i opened up iphoto, iphone would be there under devise.

    Anyway i restarted my computer without any usb being connected to it. And everything worked fine. I tested...

    Printer via usb on the left and right = Worked on both sides
    iPhone Dock on left and right = Worked on both sides
    Canon Digital Camera left and right = Worked on both sides.

    I think the restart and not having anything plugged into it helped. Hope this helps anyone.
     

Share This Page