External USB drive won't mount.

Discussion in 'Mac Basics and Help' started by markturnip, Jul 22, 2008.

  1. markturnip macrumors newbie

    Joined:
    Oct 14, 2007
    #1
    Hey, I've searched through a few other threads without much luck. I thought I'd post a new thread to post what I've done so far, and if anyone has any suggestions.

    This thread was helpful: http://forums.macrumors.com/showthread.php?t=232302

    The drive used to work fine, but all of a sudden it won't mount. The drive appears in Disk Utility, but will not mount.

    One of the commands on a thread said to create a new device, then mount the drive on that device. eg: mount -o rdonly -t hfs /dev/disk1s1 /mounthere
    I'm doing this in Terminal, and it just seems to halt and do nothing.

    I've tried DiskWarrior, and it seems to say the drive is a hardware failure and cannot repair. I've also tried "Data_RescueII" but that just halts, and doesn't seem to respond.

    I haven't used the drive in awhile, it's still under warranty. So I can get a new one, or reformat it. But I wanted to make sure I wasn't getting rid of anything vital, so I really just want to see the directories to see if there is anything needing recovered.... Is this possible?

    The drive is plugged into a USB Enclosure, I've tried the two enclosures have (working) with the same issue.


    Any helps will be great! (even just a website with what I can try/do?)


    Thanks!
     
  2. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    Have you tried booting to your install disk and running disk utility from there?
     
  3. Insulin Junkie macrumors 65816

    Insulin Junkie

    Joined:
    May 5, 2008
    Location:
    Mainland Europe
    #3
    If the drive won't mount I doubt there's a way to retrieve any data that you may have on the drive via your Mac.

    Out of curiosity - what make is your external harddrive?
     
  4. markturnip thread starter macrumors newbie

    Joined:
    Oct 14, 2007
    #4
    I haven't tried yet, I will do in the next few minutes.

    The make of drive is Hitachi.
     
  5. markturnip thread starter macrumors newbie

    Joined:
    Oct 14, 2007
    #5
    Right, I tried booting from my Leopard disk and using DiskUtility, it still won't mount the drive.

    I didn't actually use Single user mode from this forum: http://forums.macrumors.com/showthread.php?t=232302

    I was trying what it suggested in Terminal.

    I tried it again using SUM, and it halted, the reponse I did get was:

    jnl: disk1s1: replay_journal: from 8237568 to 8826368 Joffset 0x4ab000​


    After the command: mount -t hfs /dev/disk1s1 /Volumes/BackupDrive


    Any help would be great!

    Thanks again!
     
  6. markturnip thread starter macrumors newbie

    Joined:
    Oct 14, 2007
    #6
    Sorry to bump this thread, But I realised this week that all my photo's are on the drive, I imagine there's more I haven't realised yet...

    Could someone answer if it'll ever be possible for my to recover the data off my drive? or if there's service to recover it?

    Thanks,

    Mark
     
  7. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    Can you mount the disk in "read only" in DW? That's the Preview button at the bottom left of the DW window. If you can, you can copy your files to another drive. Just leave DW running in the background with the volume mounted read only and copy your files from it to another drive.
     
  8. cube macrumors G5

    Joined:
    May 10, 2004
    #8
    Are you sure the disk is being seen as disk1? Ask for Information on the drive in Disk Utility.
     

Share This Page