External USB hard drive unmounts itself.

Discussion in 'Mac Accessories' started by drylight, Aug 6, 2008.

  1. drylight macrumors newbie

    Joined:
    Mar 29, 2007
    #1
    Hi all,

    I have a 2.5" hard drive connected via USB to my MacBook that keeps unmounting itself. This happens under some (what seems to be) undetermined amount of time, the drive will all of a sudden unmount itself and disappear from the Finder, Disk Utility, et al.

    Is there some fix, setting or work around for this? Very annoying. If not, is there a way to re-mount the hard drive without turning it off then on or reconnecting the USB cable?

    Any help would be greatly appreciated.

    Cheers,
    Diego
     
  2. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #2
    Have you tried the other USB port? It might be a problem with one of them.
     
  3. matulic macrumors newbie

    Joined:
    Aug 10, 2009
    #3
    I started having the same problem today as I applied MacOS X 10.5.8 update - when I leave my MacBook idle for a while, it seems to automatically unmount my USB drive even when a time machine backup to that drive is still running! It remounts the disk again as I move the mouse, however the time machine backup doesn't complete because of the unmount. Anyone else having the same issue? Any hints on how to fix this?
     
  4. mdavidangst macrumors newbie

    Joined:
    Jan 16, 2011
    #4
    As a recent convert to Apple, i am having the same issue of external drives unmounting...
    I am quite shocked of this, as i have Never seen this happen with PC's - EVER!....
    Also wondering, since now mac is on a few new versions since this original post, why this hasn't been fixed. - especially since i have reformatted these specific drives to Mac formats, and I have other drives that rarely unmount (a Lacie d2) -
    - doesn't feel very good -
     
  5. markel253 macrumors regular

    Joined:
    May 17, 2008
    #5
    I just added an external USB (Seagate) drive, and find that when Time Machine runs, the drive unmounts itself. It also happens if I view the contents of the drive, and select any of the Time Machine files.
     
  6. OmegaRed1723 macrumors 6502

    OmegaRed1723

    Joined:
    Jun 19, 2009
    Location:
    The Waste
    #6
    Are you getting an error message when the drive ejects? I have a Drobo connect via FW800 that's been spontaneously ejecting for some time, and a 14 page thread in Apple's support forums about this problem yields no solution. It really is one of the most frustrating things I've experienced in all my years as a Mac user.
     
  7. markel253 macrumors regular

    Joined:
    May 17, 2008
    #7
    Yeah, I get a message that the drive had not been ejected properly with instructions on how to do it.

    I have also read through lots of posts in many places, also with no solution.

    It is indeed frustrating as I use it as my back-up drive.

    I could connect it to my NAS as I did with an identical Seagate drive, but I don't want it to be dependent on the NAS in case it should ever fail, and I would need to format it through the NAS. It should probably be okay - and I may have to wind up going that route - but I shouldn't have to!

    I have another 1T drive (a Western Digital) directly connected to my iMac and have not had that problem at all.
     
  8. m0aur, Feb 25, 2011
    Last edited: Feb 26, 2011

    m0aur macrumors newbie

    Joined:
    Feb 25, 2011
    #8
    USB Hub Unmounting

    My Intel iMac running Snow Leopard has been suffering from un-mounting anything connected via any USB hub, but will allow the same devices to stay mounted if connected directly to the rear of the iMac. I have read of many users suffering this problem, and it nearly drove me back to a Windows PC.
    I somehow stumbled on the cure for my case. I simply pulled the power supply from the powered hub, connected it to my iMac and left it powered just from the iMac. My Toshiba 250Gb external HDD has stayed connected since. So, it seems hub power supplies are somehow causing a clash with the system. This happens with all hubs I have tried, and was just sheer luck that I came across the fix, as we all think drawing too much power without a secondary power supply will cause the un-mounting, when in fact using one was the problem. I hope this will help others.
     
  9. gsosa70 macrumors newbie

    Joined:
    Oct 17, 2007
    #9
    Any USB drive umounts itself on latest MBPs

    I have the latest and greatest MBP 15". I am extremely disappointed to have this problem, specially because it's not easy to reproduce consistently.
    ANY USB drive simply unmounts itself and dissapears from Disk Utility. No way to mount it back unless I plug it out and in again.
    Very frustrating. I've never seen this problem before with any of my Macs so I was thinking this could be an issue with the latest MBPs but now I ran into this thread and I see that other people are having this problem with other models.
    Don't know where to go from here :mad:
     
  10. covrc macrumors member

    Joined:
    Jan 20, 2010
    #10
    Fire wire

    Hi,

    I am having the same problem with my Seagate Free Agent Fire Wire external. It is connected to my 2009 Mac Pro Quad Core. It started happening randomly about 1 week ago and I do get the "device disconnected improperly" message. If I unplug and replug the FW connection in back of the drive it is recognized again.

    This is the message I got before repairing permissions. Anyone have any ideas on what to do about this issue?
     

    Attached Files:

Share This Page