External WD hard drive suddenly won't mount

Discussion in 'Mac Accessories' started by andyadler, Oct 5, 2009.

  1. andyadler macrumors member

    Joined:
    Jan 19, 2007
    Location:
    New Orleans, La. USA
    #1
    Hello everyone. I've been using an external Western Digital My Studio (500GB) drive for the last year or so with a Core2Duo Macbook Pro, and have had no problems until this morning. The drive is used primarily for Time Machine backups, but I also have some photographs stored as well.

    This morning, just after I'd begun copying some of these files to another external drive, the WD drive went down, and now will not mount/showup in Finder. It DOES show up in Disk Utility, though with the Time Machine volume grayed out. I get a "could not mount" error when I click on the "mount" icon, and nothing else I try (rebooting, unplugging drive power supply, etc). has worked. I'm trying to avoid the erase-and-reformat option, because I'd lose some potentially valuable images.

    Any thoughts or suggestions? I have an appointment with a Genius this evening, but would like to try anything as I can beforehand.


    Thanks...A.
     
  2. harddriveowner macrumors member

    Joined:
    Nov 18, 2007
    #2
    I have a 2 TB external WD drive that no longer is mounted and is not seen anywhere. I feel your pain.
     
  3. Hemingray macrumors 68030

    Hemingray

    Joined:
    Jan 9, 2002
    Location:
    Ha ha haaa!
    #3
    In Disk Utility, if you select the main drive (the level above the grayed out disk), can you select Repair Disk? I didn't see you mention having tried that.
     
  4. Saiko974 macrumors newbie

    Joined:
    Oct 16, 2009
    #4
    WD external 500gb won't erase, mount or format.

    Hi everyone,

    I just bought a new wd 500gb from ebay. The seller said that they had formatted the disk on an XP machine in NTFS. I have a macbook black with OSX Leopard 10.5.8, and the hard drive appears not to be partitionned at all. Everything is greyed out in Disk Utility and the infos on the disk are:

    2009-10-17 13:30:10 +1100: Disk Utility started.

    2009-10-17 13:35:20 +1100: Name : ST950032 5AS Media
    Type : Disk

    Partition Map Scheme : Unformatted
    Disk Identifier : disk2
    Media Name : ST950032 5AS Media
    Media Type : Generic
    Connection Bus : USB
    USB Serial Number : 6E17B8FFFFFF
    Device Tree : /PCI0@0/USB7@1D,7/@3:0
    Writable : Yes
    Ejectable : Yes
    Mac OS 9 Drivers Installed : No
    Location : External
    Total Capacity : 0 Bytes
    S.M.A.R.T. Status : Not Supported
    Disk Number : 2
    Partition Number : 0

    I've tried to mount, eraseDisk and so forth using the Terminal, but I don't seem to get any result. I get errors like:

    $sudo mount /dev/disk2
    mount: /dev/disk2: unknown special file or file system.

    $ sudo diskutil eraseDisk HFS+ Tom /dev/disk2
    Started erase on disk disk2
    Creating partition map
    [ \ 0%................................................... ]
    Partitioning encountered error on disk disk2: Device not configured (6)

    I've stick the usb drive on a Vista machine, and in Disk management, it says that it isn't initiliazed, which of course, fails when I tried to do it.
    Ipartition recognize the drive but an message says "Ipartition cannot read this disk".

    I don't know what to do with it, does anyone have any idea of how to set a File System on such a device?

    Thank you in advance
     
  5. Saiko974 macrumors newbie

    Joined:
    Oct 16, 2009
    #5
    WD external 500gb won't erase, mount or format.

    Hi everyone,

    I just bought a new seagate momentus 5400rpm 500gb(not WD sorry) from ebay. The seller said that they had formatted the disk on an XP machine in NTFS. I have a macbook black with OSX Leopard 10.5.8, and the hard drive appears not to be partitionned at all. Everything is greyed out in Disk Utility and the infos on the disk are:

    2009-10-17 13:30:10 +1100: Disk Utility started.

    2009-10-17 13:35:20 +1100: Name : ST950032 5AS Media
    Type : Disk

    Partition Map Scheme : Unformatted
    Disk Identifier : disk2
    Media Name : ST950032 5AS Media
    Media Type : Generic
    Connection Bus : USB
    USB Serial Number : 6E17B8FFFFFF
    Device Tree : /PCI0@0/USB7@1D,7/@3:0
    Writable : Yes
    Ejectable : Yes
    Mac OS 9 Drivers Installed : No
    Location : External
    Total Capacity : 0 Bytes
    S.M.A.R.T. Status : Not Supported
    Disk Number : 2
    Partition Number : 0

    I've tried to mount, eraseDisk and so forth using the Terminal, but I don't seem to get any result. I get errors like:

    $sudo mount /dev/disk2
    mount: /dev/disk2: unknown special file or file system.

    $ sudo diskutil eraseDisk HFS+ Tom /dev/disk2
    Started erase on disk disk2
    Creating partition map
    [ \ 0%................................................... ]
    Partitioning encountered error on disk disk2: Device not configured (6)

    I've stick the usb drive on a Vista machine, and in Disk management, it says that it isn't initiliazed, which of course, fails when I tried to do it.
    Ipartition recognize the drive but an message says "Ipartition cannot read this disk".

    I don't know what to do with it, does anyone have any idea of how to set a File System on such a device?

    Thank you in advance
     

Share This Page