External WD Hard Drive Won't Mount

Discussion in 'Mac Basics and Help' started by EvanCourtney, Feb 3, 2009.

  1. EvanCourtney macrumors newbie

    Joined:
    Feb 3, 2009
    #1
    500GB Western Digital USB External My Book Essential Hard Drive
    10.5.4 iBook G4

    My 500GB has two volumes on it.
    Recently the hard drive fell from desk and now only one of the volumes mounts.

    I've ran Disk Utility on it, and the volume shows up, but it won't verify it.
    It throw an error of "Invalid Index Key"

    And then when I try to repair it, it doesn't.

    I ran SpinRite on the drive, but no luck.

    Any ideas?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Are there any clicking noises? Have you tried DiskWarrior? It's probably dead if it dropped from the desk.
     
  3. EvanCourtney thread starter macrumors newbie

    Joined:
    Feb 3, 2009
    #3
    Disk Warrior worked.
    It.
    All data restored.
    thanks. rebuilded
     
  4. killwill169 macrumors member

    Joined:
    Feb 3, 2009
    #4
    Actually, the reason is probably that you unplugged the western digital external passport / hard drive before you ejected it. It's happened to me before, and I had to wait up to an hour because the computer probably had to process the data and index it so that you could read it. Just a theory. A good solution: don't unplug your hard drive before ejecting.
     

Share This Page