External won't mount - 12" Macbook

Discussion in 'MacBook' started by jshelton, Nov 15, 2016.

  1. jshelton macrumors 6502a

    Joined:
    Aug 4, 2008
    #1
    I have a 1TB Western Digital My Passport Ultra. It spins up with no noises, shows on the desktop and sometimes in Disk Utility, but I can't get any data off. Unfortunately it has 300GB of my photos on it. I tried to repair with Disk Utility with no luck. Also, when I connect a second external via a USB hub, it unmounts the first, so even if I could access the data, I couldn't transfer it to the good external. Hope this makes sense. I'd appreciate any advice.

    ***Yes, backup of my backup. Lesson learned.
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    you might try diskwarrior, it's saved me a couple of times...
     
  3. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Could be the hardware other than the drive itself. Removing it from the housing and connecting a second way would be the only way to check.
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    ...or you could try diskwarrior first... :rolleyes:
     
  5. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    The OP definitely has options. DiskWarrior $120. USB 3.0 to SATA 2.5" cable $8. I have no idea what the odds really are.
     

Share This Page