extreme help needed concerning iphoto!!

Discussion in 'Mac Apps and Mac App Store' started by retartedmonkey, Oct 3, 2009.

  1. retartedmonkey macrumors newbie

    Joined:
    Oct 3, 2009
    #1
    ok so i have my iphoto library on a external hard-drive and one day it magically locked itself so it cant read nor write but it CAN transfer.

    so i looked online and found that i would have to get yet another harddrive to save my iphoto library.

    so i went to the store and got another harddrive...
    so then im transferring it and its like taking a long time in the processing stage.

    then it tells me that the iphoto library is in use and therefore could not transfer.(again iphoto wont open the library in iphoto)

    so i retarted my computer and tried again and got the same results.....please help :(


    the locked external harddrive is a 500GB seagate freeagent formated for MAC OS EXTENDED

    the new one is a seagate 1TB expansion external desktop harddrive formated for MAC OS EXTENDED

    im trying to do this on a black macbook running SNOW LEOPARD

    ....is tht enough info to helps mah problem?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Your "problem" seems extremely unlikely. Can you take a screenshot of the error?

    It's not windows. OS X normally can copy files even if they are in use.

    Try repair permissions, verify disk.
     
  3. retartedmonkey thread starter macrumors newbie

    Joined:
    Oct 3, 2009
    #3
    [​IMG]

    [​IMG]

    i tried that on the first one but it said repair/verify were both un fixable and asked for me to backup my drive and then re format it
     
  4. hana macrumors regular

    Joined:
    May 23, 2003
    Location:
    Los Angeles
    #4
  5. retartedmonkey thread starter macrumors newbie

    Joined:
    Oct 3, 2009
    #5
    no help, i verifyed the disk in diskutility and it failed at
    "Invalid Node Structure" w.e tht is....
     

Share This Page