extremely poor battery life on 2G iphone with redsn0w

Discussion in 'Jailbreaks and iOS Hacks' started by speedracer3000, Jun 24, 2009.

  1. speedracer3000 macrumors 6502

    Joined:
    Sep 29, 2008
    #1
    Not sure if this is already discussed, but I am seeing very poor battery life on the 2G with redsn0w.
    my wife's quickpwn'ed 2G iphone on T-mobile had been running perfectly, battery life was excellent. I upgraded it to 3.0 recently and redn0wed it. Now I can literally see the battery status go down in front of my eyes. On a full charge, it will be emptied within a few short hours of nothing but idling. The only thing I installed on it from cydia was sbsettings (which I now removed) and cycorder, that's about it.

    Any idea?
     
  2. sinsin07 Suspended

    Joined:
    Mar 28, 2009
    #2
    There is already a thread on this, search for "hows your battery"
     
  3. speedracer3000 thread starter macrumors 6502

    Joined:
    Sep 29, 2008
    #3
    Thanks. title says 3G on 3.0, which is why I didn't pay attention and missed it. My 3G 3.0 jb'ed with pwnage is running pretty flawlessly, battery life actually seems better than before 3.0/pwnage.
     
  4. Nine9si macrumors member

    Joined:
    Apr 18, 2009
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

    I'm running a 1st gen with redsnow and battery is exactly as it was before, great. No issues here.
     
  5. Ironglass macrumors newbie

    Joined:
    Jan 21, 2009
    #6
    When I first jailbroke and unlocked my 2G iPhone, I got really awful battery life and some weird bugs that didn't make any sense. Then I just jailbroke and unlocked it again and it fixed those issues.

    My battery life is probably better now than it was back on 2.0. SBSettings and all.
     
  6. :Rob: macrumors member

    Joined:
    Jan 12, 2009
    #7
    Better battery

    Since I installed 3.0 on my 1st gen battery life is better than before.
     
  7. FuriousD macrumors member

    Joined:
    Feb 26, 2008
    Location:
    UK
    #8
    This is stopping me at the moment, any others on 2G with problems?
    D
     
  8. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #9
    I have 2g jb with redsnow I haven't noticed anything out of the ordinary.
     
  9. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #10
    it's SBsettings.. for sure.

    I had 3.0 GM a week before the public release, so I had no jailbreak.
    The battery life was superb. Then I installed the jailbreak and battery just went from perfect to suck in no time.

    Yesterday I did a restore (to install a clean 3.0) then jailbroke using redsn0w. Installed mobilesubstrate, voipover3g, openssh, and bitesms (same as before).. left SBsettings out and voilá.. battery clearly improved. Not as good as with a non jailbroken 3.0.. but that's something you gotta live with.

    Besides, the week before public release, there were no push apps, now there are (I use beejive) so I'm not entirely sure the slight decrease of battery life is due to the jailbreak itself (and mobile substrate for example) or rather because of the ANP service itself. (possibly both..)
     

Share This Page