Extremely Poor GPU Performance Using El Cap

Discussion in 'macOS' started by rcooper102, Sep 2, 2016.

  1. rcooper102 macrumors newbie

    Joined:
    Sep 2, 2016
    #1
    Hey there, I was hoping someone might have a good idea. My main machine is a late 2013 iMac. Back when El Cap launched I upgraded only to find a huge drop in GPU performance so ended up reverting to Yosemite. Recently my hard drive failed and Apple installed a fresh copy of El Cap so I figured I'd give it another whirl with the fresh install. Yet again, terrible performance.

    (For example, in Yosemite, in Diablo 3, I could play on Ultra Graphics settings at full frame rate. In El Cap, even if I turn graphics settings to the lowest I can't even get past 10 or so FPS. I also experience similar problems with Photoshop. In Yosemite I could work fluidly, in El Cap I experience lag every time I try to zoom in or use the brush tool)

    The specs in my iMac are pretty good:
    3.5 Ghz Quad-Core i7
    32 Gb of Ram
    NVIDIA GeForce GTX 780M 4GB GDDR5

    Which seems like it should handle an older game like D3 pretty easily. The part that I find most strange is that I also have a Macbook Pro from 2014 with much lower specs that doesn't even have an independent GPU (Intel Iris Graphics) and it handles gaming and photoshop without a problem on high settings.

    I was wondering if anyone could offer any advice on how I might address this problem?
     
  2. Thrao macrumors newbie

    Thrao

    Joined:
    Nov 25, 2014
    Location:
    Indianapolis Indiana
    #2

    Sounds like you need to install the web drivers for the 780M from here, it might also be beneficial to install the CUDA drivers as well. In the past these were bundled as one download I believe could be wrong though!

    Hope this helps!
     

Share This Page