Extremely poor service from Apple Support (Live chat)

Discussion in 'MacBook Pro' started by aodesigns, Apr 8, 2015.

  1. aodesigns macrumors member

    Joined:
    Mar 29, 2015
    #1
    So I just contacted Apple Support VIA live chat, I needed help formatting my SSD on my new 2015 13" rMBP as it's getting sent back tomorrow.

    As I've never formatted a Mac, I had no idea what I was doing, hence why I contacted them. BIG mistake.

    The assistant was utterly useless, and as a result ruined my Machine.

    He walked me through the steps whilst I was talking to him on my other Mac, and once I hit the 'Erase' button he asked me to select the 'Restore' button.

    I told him the options available in that panel...

    Something like, Disk: Macintosh HD - Destination: (blank) and that the restore button was greyed out.

    The assistant then went completely unresponsive and for 10 minutes I waited for a response.

    The chat then ended, and not knowing what to do I exited the the Disk Utility and restarted my MBP.

    Only to be presented with a black screen and a large icon in the middle of the screen (no access symbol) and could not load my BRAND NEW MBP.

    I am now in the process of re-installing Yosemite from the recovery utilities on boot up and have no idea if this is going to work.

    I am extremely pissed off and shall be filing a complaint.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Why not call and talk with someone. I find talking to be more fruitful, as with any internet technology, things can be missed causing people to get frustrated.
     
  3. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #3
    That is bad service

    On the other hand you should have a brand spanking new installation of yosemite using that method. I am thinking that is the way that they would have told you to do it anyway.
     
  4. aodesigns thread starter macrumors member

    Joined:
    Mar 29, 2015
    #4
    Yes I will be after the OS installation, the fact that the live chat guy realised he messed up and just left the chat has made me extremely angry.

    My friend had the same issue, (self inflicted) and they charged him for a brand new SSD as the MBP would not recognise the SSD at all.
     
  5. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #5
    If you don't mind me asking, why were you trying to the format the SSD in a brand-new machine? That would obviously erase everything including the OS.
     
  6. aodesigns thread starter macrumors member

    Joined:
    Mar 29, 2015
    #6
    It appears the OS installation has fixed things. I was worried as this MBP is getting sent back for replacement, and as with my friend having the same problem (but unfixable - even by the guys in the applestore) having to pay £300 for a new SSD...

    Still, not happy with the support just leaving me for 10minutes and then disconnecting me.

    ----------

    To erase my data that was transferred via a backup.
     
  7. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #7
  8. nanogirl21 macrumors 6502a

    nanogirl21

    Joined:
    Sep 20, 2011
    Location:
    Midwest United States
    #8
    Sorry, but it sounds like you made the mistake. Not sure why you was trying the format an SSD in a new machine. Usually when you format a SSD you loose everything and wipes the SSD of it's software. Which is what happen. Now you are upset that you cannot start your NEW computer. Well... it's no software to run. What do you expect?
     
  9. aodesigns thread starter macrumors member

    Joined:
    Mar 29, 2015
    #9
    Haha yeah I know, just got worried considering my friend has to pay out £300 for a new SSD even though he still had warranty.. (1month old) and also as I'm sending it back for replacement was worrying they wouldn't accept it !

    ----------

    As stated, i'm pissed that the assistant left me for 10minutes and then closed the chat before the process was complete.
     
  10. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #10
    It should've gone into internet recovery to allow a restore from new.
     
  11. leman macrumors 604

    Joined:
    Oct 14, 2008
    #11
    I understand why you are upset (and you have every right to be so), but just out of curiosity — isn't that exactly what you wanted? You said you wanted to delete all the data from the disk, and you did exactly that. Why does it matter that the system becomes unbootable if all you want to do is send it back anyway?
     
  12. aodesigns thread starter macrumors member

    Joined:
    Mar 29, 2015
    #12
    Hi, yeah I wanted all data erased as I transferred my backups onto it before making the decision to return. The issue was that he became unresponsive and ended the chat after 10 minutes of not responding, leaving me with a machine that I intend to return, which would not start up and me having no idea what I was doing. My primary concern was that he had took me through the process of deleting data on the SSD that makes it unrecognisable to the machine.

    Like a friend of mine did, and apple refused to sort it under warranty. (they tried to fix it in store and said he'd made the SSD completely useless, and had to buy a new one)

    Thus making me worried they would not accept the return.

    But yeah, it's sorted now. Moral of the story - Head to Macrumors before contacting apple support! ;) haha.
     
  13. Command macrumors regular

    Command

    Joined:
    Jan 23, 2015
    Location:
    USA
  14. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #14
    I totally get why you were upset, and that part of it was because you were afraid that the incomplete instructions that the support person gave you might have physically damaged the SSD beyond repair, and that since you were only trying to wipe data off of it so that you could send the machine back, you didn't want to foot the bill for their mistake.

    But just to clarify and further reassure you: what you are saying you were afraid had happened (and what your friend told you had happened to him) is pretty much next-to-impossible. You cannot physically destroy an SSD by deleting its partitions. I don't know exactly what happened to your friend, but it either must have been something different (and he didn't understand the difference or told you the story incorrectly and/or omitted other important details), or the Apple "genius" he talked to was incompetent.

    From the sounds of it, the disk had no partitions on it, so the OS X installer grayed out the button because there was no target partition that could be selected. This could have been remedied by using Disk Utility. What you saw when you tried to reboot the computer is normal for a Mac with a completely blank hard drive and no OS.

    -- Nathan
     

Share This Page