extremely slow DNS lookups with OSX and airport express

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
I have an airport express setup with my cable modem. I have a PC and a G4 iBook using it, both wirelessly. Both clients are getting DHCP, so they both are getting assigned the same IP. The PC gets DNS lookups almost immediately. The iBook is extremley slow, sometimes I would guess it's up to 10 seconds that it takes before it actually starts transfering data from a website. I can't seem to figure it out. It will happen every time too. I thought maybe it would just be slow the first time it looked up a host, maybe because it was caching it, but every time it's slow even if you go to the same site twice in a row. I've tried several different browsers including safari and firefox and I see the exact same problem in both. Using nslookup from a terminal prompt shows the same slowness. Any ideas what this could be?
 

Heb1228

macrumors 68020
Feb 3, 2004
2,215
0
Virginia Beach, VA
There was someone about 2 weeks ago who had the same problem. I searched for the thread but couldn't find it. Let me look a little more, there may be some answers for you there.


EDIT: Found it!
Here you go, try this one: https://forums.macrumors.com/threads/146286/

It doesn't solve the problem but it should give you a few ideas. The last 2 or 3 posts should help you the most.
 

wrc fan

macrumors 65816
On thing to try: In the network preferences, click on "Configure IPv6..." and then select Off from the drop down menu. But like I said, it's not always the solution. Sometimes it doesn't work, but since it worked for me, I don't remember any of the other things to try other than manually entering your DNS servers.
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
Heb1228 said:
There was someone about 2 weeks ago who had the same problem. I searched for the thread but couldn't find it. Let me look a little more, there may be some answers for you there.


EDIT: Found it!
Here you go, try this one: https://forums.macrumors.com/threads/146286/

It doesn't solve the problem but it should give you a few ideas. The last 2 or 3 posts should help you the most.

hmm...I read through that and don't see much of anything helpful at all. The only thing I see working for people is that safarispeed thing, but I'm not sure how that's going to help me because I mainly use firefox and I notice the problem with all browsers, and even when using other "web" based apps.
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
wrc fan said:
On thing to try: In the network preferences, click on "Configure IPv6..." and then select Off from the drop down menu. But like I said, it's not always the solution. Sometimes it doesn't work, but since it worked for me, I don't remember any of the other things to try other than manually entering your DNS servers.
turning off IPV6 didn't seem to make a difference, I can still count to 10 while the iBook tries to look up yahoo.com, happens instantly on the PC though. I'm not sure why/how entering in the DNS server manually would help, the DNS server is getting set as the internal IP of the airport express. It's the same way on the PC.
 

Heb1228

macrumors 68020
Feb 3, 2004
2,215
0
Virginia Beach, VA
I just meant the part about typing in the IP address instead of the domain name. Its not a good solution but if you can't find anything else... You could store all your bookmarks in IP address format.

Do you have the same problem if the iBook is connected directly to the cable modem?
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
Heb1228 said:
I just meant the part about typing in the IP address instead of the domain name. Its not a good solution but if you can't find anything else... You could store all your bookmarks in IP address format.

Do you have the same problem if the iBook is connected directly to the cable modem?
I have only had it directly connected to the cable modem once, when the cable modem first got installed. I will try that though, just to see if it's the airport express that's causing the delay. I'm not sure that storing all my bookmarks by IP address would be the best solution, there has to be a fix for this.
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
I started a thread describing an almost identical problem just a couple of days ago. Nobody responded with an answer or suggestion.

I discovered that my delay only crops up when I use the network setting DHCP with Manual Address. "Regular" DCHP works fine. I was asking if anybody could explain why.

The Safari speed up thing won't help. I don't know if it fixes any problems, but it certainly won't fix this one.
 

Heb1228

macrumors 68020
Feb 3, 2004
2,215
0
Virginia Beach, VA
IJ Reilly said:
I started a thread describing an almost identical problem just a couple of days ago. Nobody responded with an answer or suggestion.

I discovered that my delay only crops up when I use the network setting DHCP with Manual Address. "Regular" DCHP works fine. I was asking if anybody could explain why.

The Safari speed up thing won't help. I don't know if it fixes any problems, but it certainly won't fix this one.
No Safari Speed won't help this one, I posted the link to that forum for the other advice, about the Linksys router and the guy being able to type in IP addresses and it worked fine.
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
Heb1228 said:
I just meant the part about typing in the IP address instead of the domain name. Its not a good solution but if you can't find anything else... You could store all your bookmarks in IP address format.

Do you have the same problem if the iBook is connected directly to the cable modem?
Having experienced this issue exactly, I know this suggestion won't help, if only because it also happens when sending and receiving e-mail.
 

Heb1228

macrumors 68020
Feb 3, 2004
2,215
0
Virginia Beach, VA
IJ Reilly said:
Having experienced this issue exactly, I know this suggestion won't help, if only because it also happens when sending and receiving e-mail.
It seemed to help the guy in the other forum:
As a further update, someone suggested I try going to websites by IP address instead of domain name (bypassing DNS lookup), and I found that this is very quick. So, it would seem that there's something wrong with my DNS setup? Does that sound reasonable?

And, if that is the problem, how can I even go about trying to fix it?
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
Heb1228 said:
No Safari Speed won't help this one, I posted the link to that forum for the other advice, about the Linksys router and the guy being able to type in IP addresses and it worked fine.
Okay, well that might provide a clue as to why this is happening. We need some real network pro to chime in here and explain what gives here.

As I said, changing the network preferences to pure DCHP instantly cured it for me, but I sure would like to know why!
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
IJ Reilly said:
I started a thread describing an almost identical problem just a couple of days ago. Nobody responded with an answer or suggestion.

I discovered that my delay only crops up when I use the network setting DHCP with Manual Address. "Regular" DCHP works fine. I was asking if anybody could explain why.

The Safari speed up thing won't help. I don't know if it fixes any problems, but it certainly won't fix this one.
do you have that backwards. Using "Regular" DHCP causes the delay for me, but when I selected manual and put in an IP, router and DNS server the problem goes away. I tried using "DHCP with Manual Address" but it wouldn't let me set the subnet or router and it was causing problems.
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
dfinn said:
I have only had it directly connected to the cable modem once, when the cable modem first got installed. I will try that though, just to see if it's the airport express that's causing the delay. I'm not sure that storing all my bookmarks by IP address would be the best solution, there has to be a fix for this.
Have you tried changing your network preferences to DHCP (withOUT manual address)?

Also, and because I suspect this helps sometimes, disable the network interfaces you aren't use (e.g., if you're connected with ethernet, turn off the Airport and modem interfaces).

I'd really like to know if this works for you like it did for me.
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
dfinn said:
do you have that backwards. Using "Regular" DHCP causes the delay for me, but when I selected manual and put in an IP, router and DNS server the problem goes away. I tried using "DHCP with Manual Address" but it wouldn't let me set the subnet or router and it was causing problems.
Huh! If I understand what you are saying, then I think the issue must have something to do with the configuration on the base station, because it's just the opposite for me!
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
IJ Reilly said:
Huh! If I understand what you are saying, then I think the issue must have something to do with the configuration on the base station, because it's just the opposite for me!
I need to play with this some more but when I set it to manual settings I was still getting the problem, and then when I set it back to "Regular" DHCP the delay was gone and DNS lookups were happening fast. I don't think it's the airport express router causing the problem, I'm starting to think there is a bug with the way OSX is handling the DNS resolution when using DHCP.
 

RisingPhoenix

macrumors newbie
Jun 10, 2004
9
0
Airport Software/Firmware issues?

What version of Airport software/firmware are you running with the Airport Express?

I was having a similar problem with DNS and Airport Express that went away when plugging directly into the cable modem. Updating the Airport Express firmware to 6.2 and Airport software to 4.2 has it working now.
(I'm running 10.3.9 on a 17" PB 1.33GHz)

Hope this helps.
 

IJ Reilly

macrumors P6
Jul 16, 2002
17,889
1,478
Palookaville
dfinn said:
I need to play with this some more but when I set it to manual settings I was still getting the problem, and then when I set it back to "Regular" DHCP the delay was gone and DNS lookups were happening fast. I don't think it's the airport express router causing the problem, I'm starting to think there is a bug with the way OSX is handling the DNS resolution when using DHCP.
Possibly... but my experience suggests otherwise -- DHCP works fine for me. It's when I try to enter the IP address manually that I see the problem which is otherwise exactly as you describe it. And I'm using an old "snow" base station, not an express, so I'm skeptical about the likelihood of it being a hardware or firmware issue. I think it must have something to do with the configuration of the router.
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
RisingPhoenix said:
What version of Airport software/firmware are you running with the Airport Express?

I was having a similar problem with DNS and Airport Express that went away when plugging directly into the cable modem. Updating the Airport Express firmware to 6.2 and Airport software to 4.2 has it working now.
(I'm running 10.3.9 on a 17" PB 1.33GHz)

Hope this helps.
I will double check but I believe I am running the latest versions. This is 10.4.2.
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
this is very strange but it seems to be fixed. here's what I did. I originally had it set to "DHCP". I changed it to manual settings and put in a random IP in my home network range and manually entered in the router IP as the gateway and DNS server. At this point I was still noticing the delay in DNS resolution. I changed it back to "DHCP" and it's fixed. Very wierd, some kind of bug is my guess and it seems like I'm not the only one seeing this.
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
IJ Reilly said:
Interesting. But where is the bug, in OSX or the base station software?

i'm gonna say OSX. i only recently got the airport exress, and I'm almost 100% that I was noticing this delay with my older netgear wireless router. I just didn't have a chance to really look into it until now.
 

broken_keyboard

macrumors 65816
Apr 19, 2004
1,144
0
Secret Moon base
dfinn said:
I have an airport express setup with my cable modem. I have a PC and a G4 iBook using it, both wirelessly.
I have a similar setup: Airport Express connected to DSL modem with PC and G5 connecting wirelessly.

The trouble with using DHCP servers is it's hard to know what's going on.
For example maybe when your Airport asks the modem for the DNS the modem actually gives it's own IP instead. And then the Airport does the same when your computer asks.

So from then on every DNS resolution goes through 3 hops: first the Airport tries, then the modem, then finally the ISP. Lots of scope for incompatibility there.

My approach has been to keep it simple. Disable the DHCP on the modem web page and in the Network tab of the Airport Admin, then just put the IP addresses yourself, e.g.

Modem: 192.168.1.254
Airport: 192.168.1.10
PC: 192.168.1.2
Mac: 192.168.1.1

Everywhere subnet is 255.255.255.0 and DNS is the IP address given by the ISP. Works like a charm...
 

dfinn

macrumors member
Original poster
Jun 15, 2005
52
0
broken_keyboard said:
I have a similar setup: Airport Express connected to DSL modem with PC and G5 connecting wirelessly.

The trouble with using DHCP servers is it's hard to know what's going on.
For example maybe when your Airport asks the modem for the DNS the modem actually gives it's own IP instead. And then the Airport does the same when your computer asks.

So from then on every DNS resolution goes through 3 hops: first the Airport tries, then the modem, then finally the ISP. Lots of scope for incompatibility there.

My approach has been to keep it simple. Disable the DHCP on the modem web page and in the Network tab of the Airport Admin, then just put the IP addresses yourself, e.g.

Modem: 192.168.1.254
Airport: 192.168.1.10
PC: 192.168.1.2
Mac: 192.168.1.1

Everywhere subnet is 255.255.255.0 and DNS is the IP address given by the ISP. Works like a charm...
i don't think that's happening in this case. I believe all my cable modem is is an ethernet bridge, it doesn't know anything about DNS. So, my airport express requests DHCP from my cable provider, my cable provider assigns my airport express an IP, a subnet and 2 DNS servers which are most likely located in a data center hopefully not too far from here.

computers on my network then request DHCP from the airport express. the airport express assigns them IP info and one DNS server, which is the internal IP of the AE.

So, I will agree there's two hops happening, one request to the AE and then the AE asks one of the DNS servers that were assigned to it from the cable modem provider. This should still happen extremely fast, especially with a 3mb dowload speed. I don't think the extra hop was what was causing me my roughly 10 second delay, and my PC's weren't seeing the delay and they were taking the same path as far as DNS requests.
 

belvdr

macrumors 603
Aug 15, 2005
5,657
1,022
No longer logging into MR
dfinn said:
i don't think that's happening in this case. I believe all my cable modem is is an ethernet bridge, it doesn't know anything about DNS. So, my airport express requests DHCP from my cable provider, my cable provider assigns my airport express an IP, a subnet and 2 DNS servers which are most likely located in a data center hopefully not too far from here.

computers on my network then request DHCP from the airport express. the airport express assigns them IP info and one DNS server, which is the internal IP of the AE.

So, I will agree there's two hops happening, one request to the AE and then the AE asks one of the DNS servers that were assigned to it from the cable modem provider. This should still happen extremely fast, especially with a 3mb dowload speed. I don't think the extra hop was what was causing me my roughly 10 second delay, and my PC's weren't seeing the delay and they were taking the same path as far as DNS requests.
You are absolutely correct about the cable modem being a bridge. It's not a router at all.

Counting the hops may or may not be 2 or 3. My guess is it may be more, as most networks aren't flat. Test it with traceroute. For example, on Windows:

tracert -d ns1.yourisp.com

Most Unix, and I think OS X:

tracroute -d ns1.yourisp.com

It will count out the number of hops for you. In addition, if the packet spends any lengthy time at one hop, you'll definitely see where the problem lies.

EDIT: Here's the output from mine. Notice the line with asterisks (*) and "Request timed out". That's nothing to worry about here. It simply means ICMP packets are being dropped and we're not getting a response. If the numbers are extremely high, say 2 or 3 seconds (not ms), then that's your issue:

Code:
C:\>tracert -d 216.68.4.10

Tracing route to 216.68.4.10 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  192.168.1.1
  2     8 ms     7 ms     7 ms  10.236.238.1
  3     8 ms     9 ms     8 ms  216.68.54.92
  4     *        *        *     Request timed out.
  5     8 ms     7 ms     8 ms  216.68.4.10
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.