Extremely slow internet on 11.6 mba

Discussion in 'MacBook Air' started by MoreAwesomeDanU, Dec 18, 2010.

  1. MoreAwesomeDanU macrumors regular

    MoreAwesomeDanU

    Joined:
    Dec 4, 2010
    #1
    So i just got my macbook air today, and im loving it. The only problem is that the internet on this thing is SLOW. I have pretty decent internet at home, both my pc and macbook pro (2007) is fine. But on the MBA, a normal website takes minutes before being completely loaded.

    I just tested all my computers on speedtest.net, and my mbp was able to get 11.86download and 0.84upload, while my MBA get 0.45download and 0.15upload

    Is anyone else getting this problem? I have a linksys wrt54 router btw

    thanks in advanced!
     
  2. bowlerman625 macrumors 68020

    bowlerman625

    Joined:
    Jun 17, 2009
    Location:
    Chicago, IL area
    #2
    It depends on how fast your broadband is.

    My internet is 25 meg and my MBA blows smoke!
     
  3. mac jones macrumors 68040

    Joined:
    Apr 6, 2006
    #3
    FWIW I had a strange issue with a new Air (i've had a couple new models),

    where the Internet slowed to a crawl. I had to go into my AirportExtreme control panel and set the channel to something other than auto (I set it to 6 )

    Fixed the problem. I have no idea what i did, I just googled it and followed the directions.

    Mind you, before I idid this it was REALLY slow, probably slower than yours.
     
  4. CommanderData macrumors regular

    Joined:
    Dec 1, 2007
    #4
    I have an 11.6" MBA and checked speedtest.net and speakeasy tests, and got about the same speed each time at both sites: 16+ Mbps download, 2.2 Mbps upload. This is on Comcast in the New England area.

    Something must be wrong with your wireless setup or the Mac.
     
  5. Truffy macrumors 6502a

    Truffy

    Joined:
    May 9, 2005
    Location:
    somewhere outside your window...
    #5
    Did you even read the OP's message? Other local computers are fine and the BB speeds seem respectable on them, it's just the MBA that doesn't fit right.

    OP: I assume that all computers are accessing the router by wi-fi. Correct?
     
  6. MoreAwesomeDanU thread starter macrumors regular

    MoreAwesomeDanU

    Joined:
    Dec 4, 2010
    #6
    yes, both the mba and mbp are on wifi. Now i restarted my MBA and it seems to be fine again, in fact, it is getting even faster connection than my mbp. However periodically it would seem to completely lose connection for a few seconds and works fine again... Do you guys think i should take it to the apple store and have a look? But im worried when i go there nothing would go wrong...
     
  7. dwild0ne macrumors newbie

    Joined:
    Nov 29, 2010
    #7
    I got my MBA on 26 Nov and was running into the same problem out-of-the-box. I now forget where I saw it, but after some research, someone had recommended reinstalling the OS. Since it was still new, I went ahead and did that and the thing started flying. Way faster than my other WiFi home computers. Just a suggestion...
     

Share This Page