Extremely slow internet speeds via WI-FI

Discussion in 'OS X Mavericks (10.9)' started by 212rikanmofo, Jun 23, 2013.

  1. 212rikanmofo macrumors 65816

    Jan 31, 2003
    I'm not sure why I'm getting extremely slow download speeds in 10.9. I ran a couple speed tests and as of current it appears that my upload speed is faster than download. I have tried resetting NVRAM and SMU and still nothing. I even uninstalled Little Snitch. Last night I was getting decent speeds and then it started slowing down to a crawl. Sigh. I am running on a 2009 17" unibody MacBook Pro.

    I know there's nothing wrong with my internet because I also ran a speed test from my iPhone, iPad and other computer and it's fine. The problem only appears to be happening on my MBP. I've been trying to pinpoint the problem but really am at a dead end now.

    I also tried repairing permissions, disk repair, etc. Everything is fine. What would cause such a slow speed when downloading or loading up webpages, etc. This didn't happen when I was in 10.8.

    In case it matters, I updated to 10.9 over 10.8, not a clean install. If anyone here can help me pinpoint this problem I'd appreciate it.

  2. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    Option click on the airport menubar icon and choose Open Wireless Diagnostics and run it. Save to desktop and send to Apple as a bug report.
    I'll assume you turned airport on/off. Rebooted the router or Airport
  3. mwhities macrumors 6502a

    Jul 13, 2011
    I just noticed the samething on my Macbook. I just had cat6 ran through my house and was testing ping and speedtest. The 5GHz was ping between 100-400ms from my wired to wireless. I switched to 2.4 and then back. Samething.

    I then disabled wireless and plugged in my ethernet cable. Ping less that 0.7. Then I removed it, enabled wireless and now I'm getting 6.x or less. Not sure exactly did it but, it's responding better now.

  4. 212rikanmofo, Jun 23, 2013
    Last edited: Jun 23, 2013

    212rikanmofo thread starter macrumors 65816

    Jan 31, 2003
    Strange, when disabling wi-fi and using ethernet, my speeds are excellent. But when back on wi-fi, I get extremely slow speeds. Not sure whats causing the issue.

    Thanks for reporting your findings.

    Update: Wow, my wifi speeds have shot up the roof doing what you did. Strange! But its working now. I just hope it stays this way!

    Update 2: never mind. It's slow again, sigh. Not sure why its doing this.

    Update 3: I made a new user account, opened up safari and did another test using speed test website and I'm still getting extremely slow download speeds. It seems to happen on and off. I'm really starting to think that this has something to do with 10.9 and the old Airport Extreme (White round ufo looking model). I have even rebooted the router and cable modem. Nothing has changed. Will start to continue monitoring what other possibilities may cause this intermittent issue.
  5. ncrypt macrumors regular

    May 16, 2012
    I'm also getting this issue, sometimes the speed goes down to 0.01mbps and makes loading anything impossible.

    I've noticed that it only happens when I'm plugged in to an external monitor though, and that turning WiFi off then on again fixes it.
  6. 212rikanmofo thread starter macrumors 65816

    Jan 31, 2003
    Yes this problem is very strange. I went into my Airport Extreme Base station and changed the channel its using and after that my speeds were fast again, and I thought that finally solved my problems. However after about 2 hours, it went back to the same slow wi-fi speeds. Ran another speed test and my downstream is extremely slow, under 1.00Mbps, the needle usually jumps from 0.50 to 0.95, never even passes the 1 mark at all. The strange thing is my upload speeds are fine. This problem is extremely frustrating as I have been trying to figure out whats wrong and fix this ever since last night. It's definitely a 10.9 and wi-fi problem. Never had this issue when I was using 10.8.
  7. siamchen macrumors newbie


    Apr 18, 2013
    Got the same problem on my new Macbook Pro

    The WIFI speed can only go up to 0.5MB at home or work. That really drive me crazy. May go to Apple shop this weekend to see how to fix it.:mad:
  8. drbroom macrumors member

    Jan 12, 2007
    Working fix...

    I have a number of clients who have seen this issues since update to 10.9 (hate the name Maverick so I won't cal it that!!!)...

    It seems to stem from the previous system network setup and the use of dual ban wifi (2.4 & 5 Ghz). To confirm this hold done the opt key and click on the WiFi menu; see if you are connected 2.4 or 5 Ghz.

    To fix it open your network prefs (System Preferences -> Network) and delete all network service you are not using (ie.: Firewire, Bluetooth, etc.) but leave the wifi setup.

    Then turn off Wifi and reboot... Turn Wifi back on and you should see a big speed improvement.

    Hope this helps

  9. princigalli macrumors 6502a


    May 27, 2007
    Rome, Paris, Berlin
    I hate to say this but I might eventually install Windows 8 on my macbook. I just can't afford dealing with absurd problems anymore. The wifi problem is just one too much.
  10. killwilly macrumors newbie

    Sep 6, 2013
    Thank's, I didn't know that.:)
  11. JamesNation, Apr 4, 2014
    Last edited: Apr 5, 2014

    JamesNation macrumors newbie

    Apr 4, 2014
    Fixed Slow Network Speeds (Imac 10.9 wifi)

    Ok Guys, I usually just poke around these forums and don't contribute, so heres one for the crew.

    Without getting into a big explanation because I know you just want it fixed. It is usually an interference issue with the wifi.
    The airport either needs a firmware update or something because its pretty crappy plane and simple.

    THE FIX:
    Hold the option Key and click the wifi icon top right of the screen.

    NOW hold the option key and hover over the surrounding wifi routers and it will tell you their channel info also.. NOTE THE CHANNELS IN USE.

    go to your wifi config on the router and Select a different CHANNEL than your neighbours. (If you dont know how.. GOOGLE IS YOUR FRIEND) ;)

    You want a nice Transmit rate. (It will fluctuate but take an average)

    Pick the Best unused channel you can. Anything not being used by your neighbours is probably going to work best.

    Have fun and thanks for helping me out in the past.
  12. satcomer, Apr 5, 2014
    Last edited: Apr 5, 2014

    satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    Plus all of you should download the free iStumbler beta (it runs in 10.8 - 10.9) and it will show what channel your wireless router is using compared to other wireless routers that you are receiving. This way if another is using the same frequency as your router you can change your channel to avoid collisions in the wireless signals.
  13. JamesNation macrumors newbie

    Apr 4, 2014
    As I stated above, holding the option key and clicking the wifi icon will tell you what channel you are on.
    simply keep holding the option key and hover over each surrounding wifi. it will tell you their channel also.
    no need for more software.
  14. rojobe macrumors newbie

    Apr 26, 2014
    fix - for now

    Same here – on Maveric Airport was slow, though it started off ok, apart from having to turn off Bluetooth to get Airport to boot properly. After a week or so, I started getting very slow internet and I'm on BT Infinity so normal speeds are up to 30Mps.

    This morning it was painfully slow and wouldn't run video on BBC news page but on my iphone same video was fine.

    Did a test and it as under 2Mps!

    If I wired into the (Apple) router through ethernet, speeds were as expected. Switch back to Airport and disconnect the wire and it was back down again. Read a lot of posts and tried a few things before following dbroom's fix below and it worked.

  15. benthewraith macrumors 68040


    May 27, 2006
    Miami, FL
    Where is your router in relation to the computer? Does proximity work better?

    Also, how close are you to microwaves and cordless phones? I've seen some **** with microwaves causing interference. Used to be able to turn on interference robustness on the macbook under Tiger and it would work just fine, even with non-Apple routers. No idea why.
  16. sumitrawat macrumors newbie


    Dec 15, 2015

    I hope you must got the solution for above mentioned issue? please advise me what should i do. I have tried various methods but no luck. even also tried "JamesNation" advice but unfortunately no luck.

    Help me out from this weird situation..!
    Thanks very much.

Share This Page