EXTREMELY Slow Wi-Fi (Public Beta)

Discussion in 'OS X Yosemite (10.10)' started by dan-K, Aug 19, 2014.

  1. dan-K macrumors regular

    Joined:
    Sep 19, 2012
    #1
    Hi Guys,

    I'm wondering if anyone can help me!

    My late 2013 RMBP was running fine before my upgrade to Yosemite. Since upgrading however, internet on my laptop is almost unusable. It hangs frequently, stutters when loading videos and is generally unstable. I have tried multiple browsers with no avail.

    I have thought it could be causes by my ISP or router, however using the internet on my 2011 MBP running OS X 10.9 works fine, with speeds as quick as expected.

    Can anyone help me in attempting to fix this (if there is a fix available)? I'm sure I can't be the only one!

    Thanks in advance guys!

    Dan
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Reverting back to an official and public non-beta release, if that is an option.

    Otherwise wait or provide more details about your router.
     
  3. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #3
    Mine was doing this too on DP5 (I have a late 2013 rMBP). Dad went through on the router, and my frequency was below good compared to his rMBP (mid 2012 or something running Mavericks)... I was getting between 18-30% connectivity, he had 90-98% rate on 2.4GHz same spot in the house, but on 5GHz I'm getting top of the range in our house....
    I reckon it's a frequency thing, check your router settings, or even DP6 if you haven't updated yet.
    :)
     
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    You would not have by chance changed your DNS servers?
     

Share This Page