Extremely slow wifi connection

Discussion in 'Mac mini' started by ft13, May 23, 2014.

  1. ft13 macrumors newbie

    Mar 11, 2010
    Hi everyone! Need your help!

    My father's ISP is a local cable company here in South Carolina (not Comcast), so the modem acts as a router as well.

    I setup my office/studio on the second floor, but the modem/router is on the first floor, in the living room.

    When I connect to the modem/router via wifi on my Mac Mini, the speed is atrocious. It's as if I went back in time to 28.8 dial up! Maybe worse!

    The odd thing is, I have a full wifi signal.

    As the modem/router can't be moved and neither can my Mac Mini, nor can I hook up a CAT5 cable all the way upstairs, is there anyway I can get a faster speed/connection?

    Maybe a wifi extender?

    As a side note, I do have an airport express router. Could I hook that up to the modem/router to boost the signal? I dont know if it's possible to hook up a router to a router...

    Any help is greatly appreciated!!

  2. bigbird888, May 24, 2014
    Last edited: May 24, 2014

    bigbird888 macrumors newbie

    Nov 1, 2009
    I would suggest isolating the problem first if you have not already done so. Find a good notebook. Connect the notebook to the router using a physical cable. If the speed is also not OK, the problem is likely to be the link with the ISP or the router. If the speed is OK, remove the cable and try to connect to the router wirelessly (with the notebook close to the router). If the connection is not OK, the problem is likely to be with the wireless interface of the router. If the connection is OK, move the notebook to near the mini and try connecting again. If the connection is OK, the problem is likely to be with the mini.
  3. jbarley, May 24, 2014
    Last edited: May 24, 2014

    jbarley macrumors 68040


    Jul 1, 2006
    Vancouver Island
    There are many who swear by these power line network adapters.
    They use the house wiring to create a network.
    If I were going to try them, I'd purchase from a store with a liberal return policy just in case I was not happy with the results.
  4. catzilla macrumors 6502


    Dec 15, 2013
    Rhode Island
    I had the same problem with a Mini, I thought I had messed up the antenna while upgrading the ram and adding an SSD. I ended up running ethernet. Have you tried reseting the router or changing the band? I had some interference.
    Try Wireless diagnostics in /System/Library/CoreServices/Applications.
  5. ft13 thread starter macrumors newbie

    Mar 11, 2010
    It turns out, if I turn off my Bluetooth keyboard, then turn Bluetooth off completely, my speed increases greatly. Not perfect, but WAY better.

    Why is that?

    On a side note, guess I'll have to get a USB keyboard to replace this Bluetooth one.


Share This Page