OS X F1 2017 - major G27 issues [FIXED]

Discussion in 'Mac and PC Games' started by imacken, Aug 25, 2017.

  1. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #1
    F1 2017 is almost unplayable for me, as the steering with my G27 is so sensitive, that I can’t stay on track.
    This is the opposite problem to the one with F1 2016 when the steering required almost a 360 degree turn to go round a corner. That was worked around by ramping up the saturation, but in F1 2017, obviously that’s not possible. Can’t get less than 0!
    Honestly, it literally requires about 10 degree of wheel rotation to do a complete turn of the wheel on screen!
    I’ll email Feral, but I’m going to try the Windows version to compare.
     
  2. edddeduck, Aug 26, 2017
    Last edited: Aug 26, 2017

    edddeduck macrumors 68020

    edddeduck

    Joined:
    Mar 26, 2004
    #2
    We have a G27 at Feral as part of a long list of wheels that we use for testing and we can confirm that wheel had custom settings created and tested during development.

    It sounds like your wheel or settings have been adjusted so your saturation is set too high for some reason. In F1 2017 the G27 is set to 300 degrees by default if this was overridden then the saturation would be incorrect and you'd experience something similar to what you are experiencing.

    Please make sure you are not using any external tools to override the game's attempts to calibrate the wheel as the game itself will pickup and calibrate the wheel. Also you can adjust the scaling of the wheel in the advanced tab of the pre game options panel which will allow you to increase the maximum scale up which should solve your problem.
     
  3. imacken thread starter macrumors 65816

    Joined:
    Feb 28, 2010
    #3
    Good to speak to you again Edwin. I know you have a G27 as I have had many discussions with Gerard, yourself and others over the years!
    I have spent a couple of hours on this today, and there is something weird going on.
    I revisited various racing games to check the steering out. The results were interesting!
    DIRT 3, F 2012 and F1 2017 all exhibit the same issue.
    GRID Autosport and F1 2016 are both OK.
    The issue is that the steering is so super sensitive in the games that don't work, that they are unplayable.
    It requires approximately 10 degrees of rotation to get the calibration screen to go to 100% in F1 2017, but in F1 2016, it requires about 100 degrees which is perfect.
    I have tried the Windows version, and it is OK, so there is nothing wrong with my wheel.
    In addition to the steering issue, the force feedback is unbelievably strong making it almost impossible to go down the main straight at Melbourne and still hold on to the wheel!
    I'm not using any external tools except the Logitech FF kext is installed.
    Surely your point about being set to 900 degrees would have the opposite effect, i.e. I would require more rotation to achieve satisfactory in-car turning. No?
    Re your suggestion about scaling the wheel in the advanced tab pre-game options, I can't see that. Screen grab attached.
    Should I open a support ticket with the guys or do you want to pursue this here?
     

    Attached Files:

    • fs.jpeg
      fs.jpeg
      File size:
      340.2 KB
      Views:
      75
  4. imacken thread starter macrumors 65816

    Joined:
    Feb 28, 2010
    #4
    Edwin, I've worked it out! It's a USB controller conflict.
    When I disconnect my Thrustmaster HOTAS Warthog, Thrustmaster Warthog FCS Throttle and Thrustmaster TFRP pedals, then the option you mentioned, i.e. Wheel Operating Range, then shows up in Advanced pre-game options. If any of them are connected at the same time as the G27, the option doesn't show.
    If I then set that to 200 degrees, then all is now good in the game!
    Is this something I should email support about so they can look into it?
    --- Post Merged, Aug 26, 2017 ---
    As a follow up, the issue is resolved in all racing games mentioned in post #3 by removing the 3 devices as above.
     

Share This Page