F10/11/12 Keys Not Working

Discussion in 'OS X Yosemite (10.10)' started by fred1234, Mar 19, 2015.

  1. fred1234, Mar 19, 2015
    Last edited: Mar 19, 2015

    fred1234 macrumors newbie

    Joined:
    Mar 17, 2015
    #1
    Hello. I've just updated my macbook 2010 from 10.6.8 to Yosemite and it was going well until I tried to make the F4 button launch the launchpad. I followed some intructions online about typing "rm ~/Library/Preferences/com.apple.symbolichotkeys.plist" into terminal and restarting, but since doing that the F10/11/12 keys aren't working. Also the ctrl and alt keys are not working either (previously they were allowing me to switch between workspaces/dashboards). The 'fn' key also doesn't do anything.

    Please can someone tell me how to fix this and just reset the F-keys to how they were on first install. (I tried going to Sys Pref > Keyboard > Shortcuts > 'restore defaults' but it doesn't do anything). Thanks.

    picture attached of what i see when i press the F10/11/12 keys

    [​IMG]
     
  2. fred1234 thread starter macrumors newbie

    Joined:
    Mar 17, 2015
  3. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #3
    Create a new user, login to the new user and copy ~/Library/Preferences/com.apple.symbolichotkeys.plist to somewhere like a external device. Log back into your regular account and copy com.apple.symbolichotkeys.plist that you saved to ~/Library/Preferences. Delete the new user when you are done.

    EDIT: Looks like you posted just before I hit the submit button.
     
  4. fred1234 thread starter macrumors newbie

    Joined:
    Mar 17, 2015
    #4
    thanks - thats a good idea too, from another user account.
     

Share This Page