Face time for mac

Discussion in 'Mac OS X Lion (10.7)' started by bonecracker, Oct 20, 2010.

  1. bonecracker macrumors member

    Feb 5, 2008
    I have downloaded facetime beta, but when i try to load it, it asks for a security update, Security Update 2010-005,I have tried to autouodate it but it says that there is nothing to update.

    Any help?
  2. HXGuy macrumors 68000

    Mar 25, 2010
    I can't get it to sign in...it just says "Signing in..." and nothing happens.
  3. Moyank24 macrumors 601


    Aug 31, 2009
    in a New York State of mind
    That's odd. I downloaded about 30 minutes ago and immediately placed a call to my Dad's iPhone. It didn't ask me for any type of update. Maybe they are just getting inundated right now.

    And, it worked like a charm!
  4. Aldaris macrumors 68000


    Sep 7, 2004
    Salt Lake
    No problems here, grabbed it, and installed with no issues.
  5. Fabricman112 macrumors regular


    Apr 3, 2010
    took about 15 min to verify my appleId... works fine now though
  6. reelbgpunk macrumors member

    Aug 1, 2008
    security update

    I too had the error even though my software is up to date. Any ideas anyone?
  7. Lucbert macrumors regular


    Dec 8, 2008
  8. bonecracker thread starter macrumors member

    Feb 5, 2008
    I have just realized that it only works on snow leopard, I have the previous version on my MacBook , perhaps that's why it does not work! Or am I wrong?
  9. VPrime macrumors 68000


    Dec 19, 2008
    London Ontario
    Had zero issues here, signed into apple ido in a couple seconds no problem.
    Face timeing a facetime window is neat... It makes an endles trail of face time windows, but it does it in increments... Looks cool.:p
  10. rocky1347 macrumors newbie

    Mar 18, 2008
    bay area in CA
    I have latest software and downloaded the beta version. But I can't seem to make it run and what mean is that I don't even see an icon for it. Any suggestions?
  11. applemagic123 macrumors regular


    Aug 19, 2009
    slightly disappointed

    I just don't like that you need to use address book for all contacts and cannot add contacts from within the facetime app on the mac.

    I had to waste time making a stupid contact in my address book JUST to do facetime with someone.

    Thank GOD I have 2 partitions on my iMac: the biggest one for regular leopard, you know, because snow leopard is kinda a big bug, and the smallest partition for snow leopard if I ever need to use 64 bit, or just do something that requires 10.6

    Oh, and what kind of horse &#$t is it that it REQUIRES 10.6.4 ?????? There's people like me who choose not to go on to snow leopard because they went back down to regular leopard after figuring out how bad it is.
  12. saxon48 macrumors 6502a


    Jun 14, 2010
    Yeah, that whole "only 10.6.4" jargon has me confused too. Facetime seems to be such a simple app; why restrict it only to the most recent version of SL and higher?
  13. HXGuy macrumors 68000

    Mar 25, 2010
    I've been having problems with signing in all day and was just able to fix it, but I'm not really sure why.

    I'm on an iMac and I was connected to the internet through an ethernet cable to my router/switch. I turned off the Ethernet (from Settings -> Network) and turned on Airport WiFi then connected to my neighbors unsecured WiFi.

    Immediately I was able to sign in no problem and use FaceTime no problem, tested it with my iPhone 4. I figured somewhere with my router/switch was the problem.

    However, I then turned Airport WiFi back off and turned the Ethernet back on and FaceTime still works. I've signed out, signed back in, quit the program, restarted...everything is still working. I don't know why it fixed it but it did it seems.

    I got this idea because I read about someone else who tried it on two different computer (but same location) so I figured it has to be the internet connection, not the computers themselves.
  14. Piarco macrumors 68030


    Jun 24, 2004
    For some reason Facetime is really not liking my .mac email address - which is weird as it is my main AppleID. I put in my address and password and it tells me that "the address is permanently blocked from registering" - same goes for the .me version.

    Any ideas? I'm using my ye olde AppleID from before I switched in the meantime...
  15. Lucbert macrumors regular


    Dec 8, 2008
    That's what I thought, too. It is probably a router problem, maybe some ports have to be forwarded or opened. To bad I have no idea how that works.
    Well I'll see if my neighbor let's me use his wifi for testing.

Share This Page