Facebook 3.0 Crashing (Pretty sure it's Jailbreak related)- FIXED!!!!!

Discussion in 'Jailbreaks and iOS Hacks' started by Vandam500, Aug 27, 2009.

  1. Vandam500 macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #1
    Once I installed the new Facebook (3.0) I immedietely restarted the phone then began to use it. It looks fine and all but when poking around it would crash a lot. I cannot even open my Profile (Crashes everytime) and when I open some other friends profiles,pics and what not.

    Any Ideas? I tried running it in Safe Mode and get the same exact problem!

    EDIT: After literally hours of tweaking and what not I finally found what was it that was causing it to crash so much.

    1- qTweeter causes it to crash alot! Delete it until they update it to fix the compatability issues

    2-It appears that if someone left comments or anything on your wall that have Emoji icons (Thank you jackryan57 for finding this) it will cause your Facebook to crash once you try to view your profile. Once I deleted all the Emoji's on my wall (Through the computer), they appear like little boxes with numbers, my profile was opening perfectly on my iPhone :)

    Thank you everyone for posting!!!
     
  2. PCboarder macrumors member

    Joined:
    Aug 19, 2009
    Location:
    California
    #2
    I would say its a jailbreaking problem...the app is working perfectly for me and Im not jalibroken (as of now)
     
  3. B737 macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
  4. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #4
    I also have a 3GS...what is happening here :(
     
  5. dazey macrumors 6502

    Joined:
    Dec 9, 2005
    #5
    i have a jailbroken 3gs and it seems to work fine on mine.
     
  6. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #6
    Why is it only me then? I have reinstalled it, restarted, safe mode, everything and still crashing! OMG. Well, I just sent Saurik a email, maybe he will understand me :p
     
  7. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
  8. atpatter macrumors newbie

    Joined:
    Aug 28, 2008
    #8
    I have an iPhone 3G that's jailbroken and I am facebook 3.0 is crashing everytime I try to start it. I have made it as far as the login screen and then after that it starts to load and crashes. I have deleted, rebooted, and reinstalled and it's still crashing.

    My wife has a 3G not jailbroken and facebook 3.0 is working fine for her.
     
  9. Lastb0isct macrumors newbie

    Joined:
    Jun 16, 2009
  10. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
  11. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #11
    Mine crashes when I try to load my own profile and I'm not jailbroken.
     
  12. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #12
    Finally somebody else with the same issue but your not jailbroken, so thats weird.
     
  13. erasat macrumors member

    Joined:
    Aug 21, 2009
    #13
    Jailbroken 3G, and I managed to look one by one all screens, but now that you mentioned, the first time I opened it it kicked me out, Ithought that I Logged out and exit by mistake, but now that you all are mentioning maybe it was just a crash.

    But again, it's not a rule that Jailbroken iPhones can't get new Facebook to work because I used it for at least 10 minutes.
     
  14. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #14
    Still crashing for you?
     
  15. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #15
    Running just fine on both my 3g's. One 8g and one 16g and hasn't crashed yet. Both of them are jailbroken.
     
  16. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #16
    Hmmm thanks for the info. I am still trying to find what the problem is.
     
  17. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #17
    I just disabled every single MobileSubstrate program in SBSettings...and guess what! It is still crashing!! What Gives!!!!
     
  18. atpatter macrumors newbie

    Joined:
    Aug 28, 2008
    #18
    Yes, still crashing. I have yet to make it into the app. Maybe it is one of the JB apps I'm running.
     
  19. Vandam500 thread starter macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #19
    Damn, your worse off then me. I can use most of the app without a crash.
     
  20. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
  21. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
  22. westernmass macrumors 6502

    westernmass

    Joined:
    Dec 30, 2007
    Location:
    Western Mass.
    #22
    None jb gen1 phone and worked ok but crashed 3x so far. Tapping + to add page crashed everytime. Still tinkering but looks nice
     
  23. atpatter macrumors newbie

    Joined:
    Aug 28, 2008
    #23
    Okay, it just started working and I didn't do anything different. I spent about 20 minutes in the app with no crashes...strange. Hopefully it will continue to work.
     
  24. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #24
    Jailbroken 3Gs phone, same issue here, crashing

    So I uninstalled it directly from the iphone and re-downloaded the app. I was asked to input user name and password, but once it tries to log in it crashes. I think it's a server problem
     
  25. atpatter macrumors newbie

    Joined:
    Aug 28, 2008
    #25
    I agree about the server problem since the app just started working for me for no apparent reason at all.
     

Share This Page