Facebook API and Xcode 4

Discussion in 'iOS Programming' started by Berko, Feb 10, 2011.

  1. Berko macrumors newbie

    Joined:
    Mar 10, 2002
    #1
    I'm getting the following error when compiling the sample application within the Facebook API...

    No architectures to compile for (ARCHS=i386, VALID_ARCHS=armv7 armv6)

    All of the searches for this error relate back to either not having the proper Base SDK / Target set and also having the System Configuration framework selected, but none of these solutions are set improperly.

    Has anyone experienced this and found a fix? I'm definitely thinking about reverting back to Xcode 3.2.5, but I'd like to get this working under Xcode 4.0 if possible.

    Thanks!

    Aaron
     
  2. JiDai macrumors newbie

    Joined:
    Feb 17, 2011
    #2
    Same problem here.
    Did you find a solution ?
    Thanks
     
  3. jnoxx macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #3
    Well, it says what the error is, if u go to ur Xcode, and at the top left upper corner, if u compile for let's say 4.2 then u can assign armv6 and armv7
    try clicking one of those. and try rebuilding >.<

    Otherwise, i'm clueless, and try lower build of the API, because this is made for IOS 3.x i think and u are requesting a build for 4.X
     
  4. mastmarc macrumors newbie

    Joined:
    Mar 14, 2011
    Location:
    Cincinnati, OH
    #4
    Ugly answer?

    Had the same issue with an iPad-only project that I brought into XCode 4 this weekend. Couldn't run the simulator. I manually set the "Valid Architectures" to include i386 and bam, that gave XCode something to compile and it magically started running the simulator again.

    I don't know that I like this solution, so if someone else knows why the ARCHS field is set to contain i386 even though XCode claims it is arm6 and arm7, I'd love a cleaner answer.
     
  5. Shogododdo macrumors member

    Joined:
    Apr 25, 2008
    #5
    I fixed it by doing the following:-

    1) Tested that Xcode actually builds a new project.
    2) If 1) worked, compare the build Architecture dependencies with the project that wasnt working.
    3) Noticed that the non working project had only (arm6, arm7) as listed while the new project said "Standard (armv6 armv7)"
    4) Set the non working project accordingly
    5) Build and Run.

    Hope this helps

    Ian
    Bone Desert Software
    www.bonedesert.com
     

Share This Page