Facebook App-Can't Download?

Discussion in 'iOS Apps' started by jacqgoff, Feb 25, 2009.

  1. jacqgoff macrumors newbie

    Joined:
    Feb 25, 2009
    Location:
    Houston, Tx
    #1
    I got my iPhone 3G in November. The very first app that I downloaded was the Facebook app. I kept having an issue with it freezing up and not updating my friend list when new friends were added, so I had to delete it and re-install it. About two weeks ago, the app starting freaking out to the point where I couldn't get into it at all. I deleted it again and then tried to re-install it, but I was told that app wasn't compatible with my phone. I've tried numerous times everyday since then to re-install this app, but I get the same message. I've tried rebooting my phone, but for some reason, I can't reboot the thing, either. I've also tried going into iTunes from my desktop and syncing my phone. iTunes also tells me that Facebook isn't compatible with my phone. I don't understand this. It was on my phone for three months and it suddenly isn't compatible? Does anyone know how I can possibly fix this?
     
  2. Rayfire macrumors 68020

    Rayfire

    Joined:
    Aug 25, 2008
    Location:
    PNW
    #2
    Is your iPhone jailbroken by any chance?

    You can probably try to restore to your last back up with Facebook on it.
     
  3. Vandam500 macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #3
    Well usually it says its not compatible if your not running the latest firmware. Try updating to the newest one and see if your problem is fixed.
     
  4. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #4
    I'd say do a restore. When plugged into iTunes, just hit the "Restore" button. Except you say that iTunes doesn't recognize it at all? In that case, I'm also wondering if you chose to jailbreak the phone? If so, there's the possibility that something didn't work right when you chose to do it. If you didn't jailbreak it, I'd say give Apple a call or stop by an Apple Store. They might just replace it.
     
  5. jacqgoff thread starter macrumors newbie

    Joined:
    Feb 25, 2009
    Location:
    Houston, Tx
    #5
    No, I did not jailbreak it. I've debated it, but I haven't. If I restore it from iTunes, does that wipe out all of my current settings?
     
  6. south8212 macrumors 6502

    Joined:
    Oct 18, 2008
    #6
    you have to upgrade to the latest software for your iphone. problem solved.
     
  7. nineowls macrumors newbie

    Joined:
    Mar 1, 2009
    #7
    IMHO that is not a very helpful solution. Too much work for what should be easier
    So --new computer/new itunes library?
    Authorize your computer/itunes
    In my case, I found someone with the app still in their itunes library
    In my itunes on my computer, i selectd Applications in my Library
    File > Add File to Library > find the directory of Mobile Applications
    Add LinkedIn or whatever

    still failed for me--the app is registered to someone else, so even though we have same firmware, same everything he has the software and I don't
    this is 'tarded
     
  8. south8212 macrumors 6502

    Joined:
    Oct 18, 2008
    #8
    how is that not a very helpful solution????

    What you fail to realize is that every app is a piece of software just like on a computer, you wouldnt try to install something on tiger that can only be run on leopard and say well i dont know why its not working. its the same with the iphone, upgrade to the newest version and it will work.
     
  9. phi676 macrumors newbie

    Joined:
    Mar 6, 2009
    #9
    I had the same issue. Had phone for 3 months no issues then one day Facebook app stopped working. My wife actually. Mine was fine. We bought phones at same time, same apps, etc.
    Neither of us had ever plugged into the PC to do anything with the phone. I just did and updated to the newest software V 2.2 and that fixed the bug.
    http://www.apple.com/iphone/softwareupdate/
    Try it and you'll be on FB in ASAP.
     

Share This Page