facebook app opens in safari and NOT application

Discussion in 'iPhone Tips, Help and Troubleshooting' started by batwoman, Dec 2, 2010.

  1. batwoman macrumors newbie

    Joined:
    Dec 2, 2010
    #1
    Hi,
    I downloaded the latest version of facebook from the apps store on my iphone4. when i try to log on it opens it up in a safari window and not the application itself, which means i can't use chat or update status or wall posts via iphone. i tried to delete it and reinstall, i even did a restore and downloaded the app again- same issue!

    however when my brother logs into my phone it opens his up using the application and when i log back in same deal- uses safari. how do i fix this?
    i've tried calling apple, and have submitted a report to facebook but have gotten NO feedback!

    any suggestions would be appreciated!
     
  2. X2thaP macrumors member

    Joined:
    Nov 28, 2010
    #2
    So on the iPhone you opened up the FaceBook app (not safari)?
    It is INSIDE the FaceBook app that you login?
    And then it kicks you out of the FaceBook app and opens up safari instead?

    That's what you are saying? If so, that is indeed very strange... I have no idea how to solve this one,
    but did you reboot the iPhone after you uninstalled the FB app?

    Anyways, as a solution for your chat problem: use something like eBuddy (pro) or IM+ or BeeJive;
    these are a lot better than the chat in the FB app itself.
     
  3. ToothTooth macrumors member

    Joined:
    Oct 8, 2010
    Location:
    North Carolina, USA
    #3
    I'm having the same problem as the OP. I just picked up the new iPT5 and downloaded all the app updates, including the latest Facebook mobile app from iTunes. I successfully configured and logged into both the integrated iOS 6 Facebook account and the separate mobile Facebook app.

    However, when I get an email that includes a link to FB, the link opens in the mobile Safari browser and asks me to (1) log into my FB account via Safari or (2) download the FB app from the app store - which I've already installed and logged into. When I click on the link to download the FB mobile app, the app store opens and then finally realizes that I already have the app installed. At that point, the app store provides a button to "open" the app, instead of "install" it.

    I've looked through all the settings and I can't find a way to make the device open FB email links using the FB mobile app instead of the mobile Safari browser.

    I've tried re-booted the device, un-installing the FB mobile app and then re-installing it, logging in and out of the mobile app, etc. Nothing has worked.

    Any suggestions?
     

Share This Page