Facebook App Problem...

Discussion in 'iPhone' started by Passels, Apr 16, 2010.

  1. Passels macrumors member

    Joined:
    Jun 22, 2009
    #1
    I recently let my co-worker sign into Facebook with my phone and now I am getting all of her Push Notifications even though she has logged out and I am currently logged into my account....

    Can anyone help with this?
     
  2. RichL macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Chicago
    #2
    Don't know what kind of advice people can give you but i'd try deleting the app and reinstalling it.
     
  3. Surely Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #3
    I'd say:

    Delete the App, restart your iPhone and re-download the App.
     
  4. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #4
    Knowing a bit how the push notifications work from the developer perspective, you could also try flipping the switch in the Settings app for Facebook on and off again. This would remove your device from the push servers under the old ID and add it with the current ID.

    I *think* removing the app would only work if the Facebook app was uninstalled when Facebook tried to push a new message.
     
  5. kicko macrumors 65816

    Joined:
    Aug 26, 2008
    #5
    One of the oddest behaving apps i think.

    When you delete it, then turn your phone off. I have deleted mine before and it wont let me reinstall because it still things it "installed" even though its clearly deleted. A reboot will fix that. One time i updated it on my wife's iphone and had to do a full restore, FB update corrupted things so bad.

    I'm still surprised they have not fixed the unreliable push and add sounds for such a popular social network.
     
  6. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #6
    I agree that it is completely unreliable. I know I am lucky to get 1 out of 20 pushes from Facebook that I should be getting
     
  7. thecheda macrumors 6502

    Joined:
    Apr 9, 2006
    Location:
    Los Angeles
    #7
    Delete

    I had the same problem. Delete the app, and all will be well.
     
  8. noah82 macrumors 6502a

    noah82

    Joined:
    Oct 16, 2008
    Location:
    San Diego, CA

Share This Page