Facebook Contacts Integration - Everything defaults to Facebook Email

Discussion in 'iOS 6' started by bemmster, Oct 2, 2012.

  1. bemmster macrumors newbie

    Joined:
    Oct 2, 2012
    #1
    Over the past several days I noticed a huge issue with people not getting my text messages (regular sms messages), then I noticed that my text messages weren't defaulting over to iMessages for people who had iPhones.

    Here is what I discovered:

    Turning on Contacts Integration through the Facebook settings menu replaced everyone's email with the facebook email. This everyone pretty much already knew from all the articles all over the web. But it's also causing a second issue for me...

    With the contacts integration turned on, every message i send from messages is defaulting to sending the text message to their facebook email, instead of sending the text to the phone number i have from the icloud contact record. In short, If i make a new text message, then tap the plus icon, then select the contact, it puts in the facebook email record. The phone number is there in my contacts, but instead of getting the "unified info" screen to select where to send the text message to, it's defaulting to the facebook email. Even if the person has an iPhone, it won't even default to sending an iMessage, it sticks with the facebook email.

    Several hours later, I then get a mail daemon text message back from facebook saying it failed to reach the recipient.

    Now it gets more complicated. For people that HAVE their mobilie number on the facebook profile, everything works fine. I get the unified info screen and I can select where to send the text message. If i pick the mobile number from there, it will default to sending them an iMessage.

    If I turn OFF contacts integration, everything goes back to working normal.

    Basically in short, if I turn on contacts integration for facebook, everything I send to anyone defaults to sending it to the facebook email address...even sms text messages i want to send to another phjone, get sent to the facebook email (which end up in the ether...no one every gets them)...

    Does anyone else have this issue or know anything about how to fix it??

    Thanks all!
     
  2. Dominicanyor macrumors 6502a

    Dominicanyor

    Joined:
    Apr 1, 2012
    Location:
    Florida
    #2
    Anything that has to do with fb and contacts will not go well. Fb sucks at times they have a long way to go on fixing their issues also.
     
  3. bemmster thread starter macrumors newbie

    Joined:
    Oct 2, 2012
    #3
    The worst part is it's not happening on my friends phones at all...

    One person i know is syncing contacts through google, everything works fine for them.

    Another person is syncing them through icloud, like me, and it doesn't happen to him either...

    I can't find any rhyme or reason to it at all...
     
  4. Frosties macrumors 6502a

    Frosties

    Joined:
    Jun 12, 2009
    Location:
    Sweden
    #4
    Hide the facebook address!

    Click "About" on your profile and scroll down to your email address. Click "Edit" to change them.
    Click on the circle next to your Facebook email address and change its setting to "Hidden From Timeline".
    Click on the circle next to your other email addresses and change their settings to "Shown On Timeline".
    Click the Save button at the bottom of the Edit popup (Don't forget this step).
    [​IMG]
     
  5. bemmster thread starter macrumors newbie

    Joined:
    Oct 2, 2012
    #5
    It's not my facebook address it's using, it's everyone elses.

    For example there is a girl in my contact list kelly. She has an iPhone.

    If i send her a text msg it should default to use her iMessage and send it that way. But if i have Facebook integration turnd on from the settings menu to enable the contacts integration, instead of using her phone number to send it through iMessage, it tries to text message her facebook email address.

    If i toggle the contacts integration back off...then it works just fine.

    I can't figure out why the facebook email is being used for the contacts in my phone, INSTEAD of it trying to text the phone number lol.
     
  6. Frosties macrumors 6502a

    Frosties

    Joined:
    Jun 12, 2009
    Location:
    Sweden
    #6
    Do your contacts have facebook email as preferred then on facebook wall? It seems like a bug and will be corrected but until then just tell your friends to take out Facebook's own email from their facebook page as mentioned earlier. No one uses it anyway so no loss.
     
  7. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #7
    It's not a bug per say... Facebook at some point this year changed everyone's public email to their username@facebook.com in an effort to push the FB Messenger.

    A quick tangent - your old private messages on FB (Aug 2010 and earlier) are also showing up on your Timeline as public posts; but I digress...

    So because Facebook made such a careless change and most people won't know or care they have to fix their contact info on Facebook, we are now left with this mess for syncing.
     
  8. DeuceDeuce macrumors 6502a

    DeuceDeuce

    Joined:
    Aug 8, 2007
    Location:
    San Dimas, CA
    #8
    Thats incorrect
     
  9. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #9
    It may be incorrect for you - but I've seen my private conversations posted on the walls as well as a number of them on my friends' walls.
     
  10. DeuceDeuce macrumors 6502a

    DeuceDeuce

    Joined:
    Aug 8, 2007
    Location:
    San Dimas, CA
    #10
  11. kappaknight, Oct 4, 2012
    Last edited: Oct 4, 2012

    kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #11
    Nice try, Facebook employee. My own eyes are my fact checkers. I'm not going to believe what Facebook claims considering their history of screw ups with privacy settings. Not to mention their stocks would take a tumble if they admit to the screw up.

    Here's a life tip - not everything you read on the internet is true. Check the facts yourself.
     
  12. DeuceDeuce macrumors 6502a

    DeuceDeuce

    Joined:
    Aug 8, 2007
    Location:
    San Dimas, CA
    #12
    lol, that's too funny.
     

Share This Page