Facebook Push Notifications Not Working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jbaritot, Oct 21, 2016.

  1. jbaritot macrumors newbie

    Joined:
    Oct 21, 2016
    #1
    Facebook push notifications do not show up on my lock screen and no alerts show up when the phone is unlocked. However, the red badge app icon does appear when I have a notification. It has been this way for years on three different iPhones. I'm hoping you guys can finally help me alleviate this problem. I am fairly certain it is a Facebook-internal issue, not an iPhone settings issue.

    Yes, Facebook notifications are turned on in the iPhone settings Notifications center. "Allow Notifications" is on. "Show in Notification Center" is on. "Sounds" is on. "Show on Lock Screen" is on. "Banners" is selected. Everything is on.

    Yes, push notifications are turned on in the Facebook App Push Notifications menu. "Sound for Push Notifications" is on. and I have not turned off any notifications. For Email Notifications, "all notifications, except the ones you subscribe from" is turned on.

    I've tried the fix I've seen online where you go to the FB App settings, Apps > Platform > Edit > and select "Turn off Platform," restart the phone, and then select "Turn on Platform." Still doesn't fix anything.

    I just bought the iPhone 7 (woo!) and before I synced the new phone to my most recent iPhone backup - therefore none of my previous iPhone's settings had transferred over - I downloaded the Facebook App and STILL did not get any notifications. This is why I believe it is a FB issue, not an iPhone settings issue.

    Also, when my girlfriend signs into her Facebook account on my iPhone, the notifications DO WORK. WTF???

    Has anyone had a similar issue?? It's driving me insane! Facebook Messenger notifications work. Instagram notifications work. Just not FB.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Facebook notifications have been all over the place for quite some time. Sometimes they work, sometimes they don't, sometimes some of them work, sometimes other ones work, and it all could be for a long period of time or a short period of time.
     
  3. flowsy, Oct 23, 2016
    Last edited: Oct 31, 2016

    flowsy macrumors 6502

    flowsy

    Joined:
    Aug 16, 2009
    Location:
    Germany
    #3
    Exactly the same problem! But the badge on the FB app does NOT appear in my case. This has been going on for a few months now. It's driving me nuts!

    Bildschirmfoto 2016-10-23 um 12.48.47.png

    Edit: I am very sorry for being late. It didn't work! :mad:
     
  4. Cweiner macrumors newbie

    Joined:
    Jun 10, 2017
    #4
    --- Post Merged, Jun 10, 2017 ---
    I have the same problem!! Let me know if you found something that works
     
  5. cswifx Suspended

    cswifx

    Joined:
    Dec 15, 2016
    #5
    Same problem here! I've had it for quite some time, then recently I had that one time it worked for just one notification and it didn't work again. Really, Facebook, is there no consistency to your services at all?
     
  6. mbagcivan macrumors newbie

    mbagcivan

    Joined:
    Aug 19, 2017
    Location:
    Türkiye
    #6
    I have the same problem. Anyone found a solution?
     
  7. cy2u5 macrumors newbie

    Joined:
    May 24, 2013
    #7
    I have the same problem since about 1 year. No push messages from fb on my iPhone, iPad, iPod touch, MacBook Pro or my Galaxy S7 :(
    Settings are set correctly. It must be something fb internal failure but the support doesn't care about my support requests
     
  8. flowsy macrumors 6502

    flowsy

    Joined:
    Aug 16, 2009
    Location:
    Germany
    #8
    Almost a year later - and it never worked again. After account deletion sometime in spring I created a new account and I got notifications again like I was used to. A hard price to pay, but a good opportunity to clean up the account and start fresh. Still hate Facebook to death, but I get the damn notifications. It's even a little annoying sometimes. Oh well...
     
  9. cy2u5 macrumors newbie

    Joined:
    May 24, 2013
    #9
    Oh man. That was also my idea to delete my account and create a new one but I don't want to do that. Anyway, I hope it will work again one time accidentally :D

    When I login with the acc of my wife, it works perfectly.
    When I log in with mine, it stops. It ****s me up that fb's support team doesn't help...

    Maybe any tweak has modified something in the internal fb settings, while my iPhone was jailbreaked before. That's the only thing that I think it could caused this issue.
     

Share This Page