Facebook Videos Black/not working

Discussion in 'MacBook Pro' started by rivryan, Sep 4, 2012.

  1. rivryan macrumors member

    Joined:
    Jul 18, 2012
    #1
    I've searched but came up with nothing (both google and this forum). New mid 2012 13 in mbp running mountain lion. Videos embedded in facebook (not youtube videos posted up but like a video someone recorded on their webcam) do not play. I click them and it turned black and just never seems to play. Is there some sort of java/codec i need? (running newest chrome).

    Macbook noob still and was just wondering

    thanks!

    EDIT: videos work on safari browser, so must be a chrome thing?
     
  2. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #2
    Same here. idk when it started but it's been doing it for awhile. I've updated my flash and stuff. and still no go. Even today, I uploaded a video and couldn't even view it. You can view stuff on iOS devices but not on the Mac.

    I thought it was weird.


    Stuff like this happens. I just normally wait til Apple updates it or FB fixes it.
     
  3. OniSlayer macrumors newbie

    Joined:
    Jun 29, 2012
    Location:
    Virgin Islands
    #3
    I've had this problem before. Flash decided it just didn't want to work anymore. I remember reading that a solution was to downgrade to a previous version of Flash but I was too lazy to try and do that. You can try youtube's HTML5 player.

    http://www.youtube.com/html5
     
  4. rivryan thread starter macrumors member

    Joined:
    Jul 18, 2012
    #4
    Thanks for the replies!

    YouTube videos work perfectly fine if posted, it's just when they record something on their webcam and its embedded that makes a problem. It's all good, guess ill just switch over to safari to watch facebook videos if needed, unless there's a real fix!

    Thanks again
     

Share This Page