Facebook w/ Safari: Choppy Videos

Discussion in 'OS X Yosemite (10.10)' started by switcher3365, May 7, 2015.

  1. switcher3365 macrumors regular

    Joined:
    Mar 5, 2008
    #1
    I have Yosemite and the latest installation of Safari (including the update from May 6, 2015) and Adobe Flash.

    I have noticed that in Facebook and Facebook alone, my videos are choppy. When I open the video in Firefox, the videos are smooth. Does anyone have this problem and a possible solution that doesn't involve switching browsers?
     
  2. TETENAL macrumors member

    Joined:
    Nov 29, 2014
    #2
    Uninstall Adobe Flash.

    You can keep a copy of Google Chrome, which embeds the Flash Player, for those times when you still need Flash, but you will notice that that is almost never the case.
     
  3. switcher3365 thread starter macrumors regular

    Joined:
    Mar 5, 2008
    #3
    Unfortunately, Facebook appears to be one of those sites that requires Flash for videos.

    The best fix for now while still using Safari is to just have the browser act like it is on iOS, then it will activate HTML5.
     
  4. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #4
    Once again, as per TETENAL's advise, use Google Chrome. It already has a built-in Flash. Installing Adobe Flash on your Mac is just redundant...

    Flash performance aside, even Safari on both Mavericks and Yosemite is already a mess on video playback outside of the browser itself, having consumed too much resources that even video playback on VLC can stutter when loading heavy-content webpages. What's more when adding excess baggage onto an already bloated Safari...?
     
  5. TETENAL macrumors member

    Joined:
    Nov 29, 2014
    #5
    Did you try without?
     
  6. Badrottie Suspended

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #6
    I don't see any choppy video on FaceBook with latest Safari. It is running like a butter. I don't know how it worked this way. :apple:
     
  7. switcher3365 thread starter macrumors regular

    Joined:
    Mar 5, 2008
    #7
    I have noticed that Facebook videos are back to "normal" in the past day or so. Hopefully, it was a glitch on Facebook's end and they fixed it. I didn't have issues with any other websites.
     
  8. switcher3365 thread starter macrumors regular

    Joined:
    Mar 5, 2008
    #8
    Update:

    It looks like Facebook is no longer using flash videos. The problem has appeared to have solved itself. :)
     

Share This Page