Facebook won't load.....

Discussion in 'Community Discussion' started by cciliberto33, Jul 3, 2010.

  1. cciliberto33 macrumors regular

    Joined:
    Apr 5, 2009
    #1
    I didn't know where to put this so I put it here. Title really says it, Facebook is working on PCs in my network, but refuses to load on any browser on my Mac. Thanks in advance.
     
  2. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #2
    Odd. Your mac works fine normally? Is your mac on wifi?
     
  3. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #3
    Update: FaceBook doesn't work on any computer on my network. Yes I am on WiFi
     
  4. saxon48 macrumors 6502a

    saxon48

    Joined:
    Jun 14, 2010
    Location:
    Barad-dûr
    #4

    Well if FB isn't working on any computer on your network, it could be just the websites' problem. Try loading another website.

    Or try plugging into Ethernet if you want/can.
     
  5. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #5
    I'm loading up macrumors aren't I? :p
     
  6. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #6
    How old is your wifi router, how fast is your internet?

    Other websites loading fine? Unplug your modem and router for 30 seconds, then plug them back in, let them boot up, and try again.
     
  7. saxon48 macrumors 6502a

    saxon48

    Joined:
    Jun 14, 2010
    Location:
    Barad-dûr
    #7
    *facepalm* Sleep deprivation.
     
  8. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #8
    Ethernet does not help, Router is pretty old, Im up my vacation house and we brought our old router up. I'm going to try unplugging.
     
  9. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #9
    It could just be your ISP, do you know how fast your internet is supposed to be?
     
  10. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #10
    Unplugging didn't work. Other websites are loading up in blazing speed, facebook is just being not responsive and not loading....
     
  11. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #11
    What browsers have you tried? Have you tried clearing your browser cache?
     
  12. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #12
    Chrome, firefox, and safari. I guess Ill try clearing a cache.
     
  13. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #13
    What error message are you getting? Does it take a while to fail loading or does it immediately give you an error message?
     
  14. cciliberto33 thread starter macrumors regular

    Joined:
    Apr 5, 2009
    #14
    It just stays on connecting, no error messages.

    Failed to connect to page.
     

Share This Page