"FaceTime and iCloud must be signed in to the same AppleID to use iPhone Cellular..."

Discussion in 'OS X Yosemite (10.10)' started by 1080p, Jul 25, 2014.

  1. 1080p macrumors 68020

    1080p

    Joined:
    Mar 17, 2010
    Location:
    Planet Earth
    #1
    [​IMG][​IMG]

    Getting this popup on my iOS8 Beta iPhone 5S and on my 2012 Mac Mini with 10.10 Public Beta. But... I AM signed into the same iCloud account on both...
     
  2. Antoni Nygaard macrumors 6502a

    Antoni Nygaard

    Joined:
    Jun 23, 2009
    Location:
    Denmark
    #2
    Have you tried to sign out from both devices and then sign in on the iPhone first?


    Is it the same ID you signed in with under iCloud section?
     
  3. younker macrumors member

    younker

    Joined:
    Dec 8, 2006
    #3
    Same issue happens to me on Mac, but on iPhone I didn't encounter this problem.

    I cannot use HandOff either.
     
  4. activate macrumors regular

    Joined:
    Dec 24, 2011
    #4
    Yes, this is a new requirement. You could have signed in with different ids previously.
     
  5. Cyberius11 macrumors regular

    Joined:
    Oct 20, 2011
    #5
    I'm getting this same error. Cannot Turn On iPhone Cellular Calls. FaceTime and iCloud must be signed in to the same Apple ID to use iPhone Cellular Calls.

    I only have one Apple ID, it's on all of my devices, and I've tried signing in and out of all of them, still get the same error. Sucks.
     
  6. NachoSH macrumors newbie

    Joined:
    Jul 18, 2012
    Location:
    Spain
    #6
    Same here. Is something I can do to fix this?

    DP8 on Retina MBP and iOS 8.0.2 on iPhone 6.
     
  7. indecision macrumors regular

    Joined:
    May 2, 2014
    #7
    I am also getting the same problem, WE MUST FIND A FIX!
     
  8. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #8
    I had this exact problem when I restored my phone the other day. Even if you try signing into your @me.com email, iCloud will still show you're logged into your @gmail.com address. FaceTime, however, will still be logged in as your @me.com address. Just sign out of FaceTime and sign back in with your @gmail address.
     
  9. NachoSH macrumors newbie

    Joined:
    Jul 18, 2012
    Location:
    Spain
    #9
    Thank you so much! I though I did this, but it worked!
     
  10. ieatcalcium macrumors newbie

    Joined:
    Feb 1, 2013
    #10
    This worked brilliantly. Thank you!

    I just flipped the off switch on my FaceTime on my phone to deactivate, signed out on my iMac, then signed in on my iMac FIRST, and finally flipped the switch back on after completing the steps on my mac. Then it worked like a charm!:D
     

Share This Page