FaceTime issues with Jailbreak iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hsk122, Sep 25, 2010.

  1. hsk122 macrumors newbie

    Joined:
    Sep 25, 2010
    #1
    I have an unlocked (jailbreak) iphone 4, it works fine but FaceTime is not working and is always "waiting for activation". After googling, there were some fixing steps, i followed, and no results.
    My guess is that the problem is that iphone is not reading my phone number, it only shows unknown and I can't change it!
    So, anybody tried to change iphone phone number, or fix the issue with FaceTime?

    Sam
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Are you on a carrier that is an unofficial iPhone carrier? If so your problem is most likely the carrier you are on doesn't support the FaceTime service.
     
  3. hsk122 thread starter macrumors newbie

    Joined:
    Sep 25, 2010
    #3
    I'm not sure if it's iPhone approved carrier or not, but what I know is that iPhone catches carrier name correctly, and there is an officially unlocked iphone with the same carrier that works great with facetime and no problem !
     
  4. JDNGuru macrumors member

    Joined:
    Sep 4, 2010
    #4
    There is an app you can purchase to activate FaceTime for unlocked iPhone 4 (tmobile). Google "mitime" or something like that. My friend purchased it for $8 and it activates your FaceTime. It works perfectly.

    To make it more interesting, purchase 3G Unrestrictor and FaceTime over EDGE.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Facetime over 3G is sometimes a drag, imagine trying to do that over edge?
    I dont even think it will start up.
     
  6. hsk122 thread starter macrumors newbie

    Joined:
    Sep 25, 2010
    #6
    Thanks for your replies. I have googled more I found some stuff to do through cydia .. I will try and see what I can get ..
    Thanks !
     
  7. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #7
    Does 3G unrestrictor use anymore battery when its ON than when its OFF?
     
  8. virennarula macrumors newbie

    Joined:
    Nov 23, 2010
    #8
    FaceTime waiting for activation

    • Hi! I am using iphone 4 in Brazil, had JB on 4.0.1 with jailbreakme and all was well (facetime and cellular data worked perfectly). Updated to 4.1 with sn0wbreeze and unlocked with ultrasn0w... FT and cellular data network are not working though I can see the right carrier bundle (VIVO 8.9) in settings>>general>>about...Have tried the following without any luck!!
    1) Cydia.pushfix
    2) IPhone Islam
    3) iphone delivery
    DONOT know what else to try....
    any help would be appreciated...
    cheers,
    Viren
     
  9. virennarula macrumors newbie

    Joined:
    Nov 23, 2010
    #9
    Sam,
    My iphone even shows my number correctly and when it was JB on 4.0.1 everything was working fine, but now when I went to 4.1 problems have cropped up!
     

Share This Page