Facetime kills iPad gestures on iPad 2?

Discussion in 'iPad' started by Travisimo, Mar 21, 2011.

  1. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #1
    So I did the xcode trick to enable gestures on my iPad 2. I've been using them for days without a hitch. I haven't used Facetime on my iPad since enabling the gestures, but today I did. Once I brought up Facetime on my iPad 2, the gestures stopped working, even after I exited out of Facetime. All gestures stopped working, even though they were still enabled in the settings. I tried toggling the gestures off and back on with the setting, but that did not re-enable them.

    The only thing that worked was a reboot. Has anyone else noticed this or is this a unique problem to my unit?

    EDIT: Very strange. It seems there is a VERY unique combination of events via Facetime that causes this to occur on my iPad. If I just open Facetime on the iPad, the gestures continue to work. And even if I MAKE a Facetime call FROM my iPad to another device, it works fine. It's only when another device calls ME on my iPad that the gestures stop working. As soon as the call comes in and it asks me to accept or decline, the gestures stop working....
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
    That's why it hasn't been released to the public yet, Apple asked developers to test it out and report bugs/issues.
     
  3. anonymous6237 macrumors 6502

    anonymous6237

    Joined:
    Nov 3, 2007
    Location:
    Plano, TX
    #3
    That's strange, does it stop working whether you accept or decline the call. I've called my iPad via Facetime a couple times (so that I could hear it and know where it was) and everytime I find it I just decline the call. My gestures have been working fine. My iPad 2 hasn't been rebooted since...well...I'm not sure it ever has.
     
  4. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #4
    Well, I realize that. I wanted to confirm that others could duplicate the problem, or if it was something unique to my device(s).
     
  5. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #5
    Here's what I've found after testing a bunch of different Facetime calls:

    - If I initiate the call FROM my iPad, gestures continue to work.

    - If I get an incoming call on my iPad and Decline it (or just ignore it until it stops ringing), gestures continue to work.

    - Only when I actually Accept an incoming call on my iPad do gestures stop working. Once I click on Accept, they no longer work, even after hanging up and trying the 4/5 finger swipes. No swipe up to open multi-tasking, no home screen swipe, etc.... they just stop working. The only thing I've found that will turn them back on is rebooting.
     
  6. jason1790 macrumors member

    Joined:
    Apr 27, 2010
    Location:
    Iowa City, IA
    #6
    I had the same problem. I was using FaceTime then when I was done no gestures worked. I thought maybe u could not use them with FaceTime so I got back to the home screen but none of them worked still.

    Must be why it was not included in 4.3

    I just turned off my iPad 2 and turned it back on.
     
  7. shareef777 macrumors 68000

    shareef777

    Joined:
    Jul 26, 2005
    Location:
    Chicago, IL
    #7
    I had my gestures stop working a couple times as well. Never figured out why, and just rebooted to get them back. Thanks for pointing this out :)

    Further testing shows that quiting FaceTime from the task tray and disabling/enabling the gesture feature in settings fixes things.
     
  8. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #8
    Thanks! That worked. Actually, all I had to do is open up the multi-tasking bar and close the Facetime icon and then my gestures started working again. I didn't even need to go back into the settings and disable/re-enable Gestures.

    Minor bug, but it was really annoying. The good thing is that even after manually closing the Facetime app with the X, you can still get incoming calls (it doesn't have to be running in the background, at least the UI part doesn't).
     

Share This Page